[l10n_site] Getting rid of l10_site and find new home for auth/backends.py

VERIFIED DUPLICATE of bug 657872

Status

--
minor
VERIFIED DUPLICATE of bug 657872
8 years ago
7 years ago

People

(Reporter: peterbe, Unassigned)

Tracking

Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
l10n_site used to be the directory that hosed the django root itself. Now it has turned into an app and the only thing still used inside it the `auth/` module. 

`ldap_settings.py` has been moved into `settings`.
We could move auth into apps/accounts or, maybe even better, to lib.  Thoughts?

Comment 2

8 years ago
accounts would mean that this is a global module accounts, that sounds really general, and conflict happy.

Maybe elmo_accounts ?

I'm not sure about lib, that sounds like taken by playdoh. I'd rather not run into conflicts there.
(Reporter)

Comment 3

8 years ago
-1 on "lib" and -1 on "apps/accounts". accounts is all about authorization. 

I'd be quite happy to make it a module in the root. That's where I've put similar things like that in the past. It's not an app after all.
What is the purpose of `lib` then? Agreed on accounts.
(Reporter)

Updated

8 years ago
Depends on: 656232
(Reporter)

Comment 5

8 years ago
After reconsideration I've decided that "lib/" is a good place to put "auth/". Now made a patch that not only adds tests and fixes bugs but also moves "auth/backends.py" into lib. See https://bugzilla.mozilla.org/show_bug.cgi?id=656232 
Added dependency on that bug. As far as I can see, l10n_site can be deleted once 656232 is resolved.
(Reporter)

Comment 6

8 years ago
Closed as a dupe
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 657872
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.