Slow when deleting messages

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Jeff Grossman, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [support][antivirus: MSE])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.35 (KHTML, like Gecko) Chrome/13.0.761.0 Safari/534.35
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0a2) Gecko/20110509 Thunderbird/3.3a4pre

It takes about 2-5 seconds for the message window to close when hitting the delete button.

Reproducible: Always

Steps to Reproduce:
1.  Open a window in a standalone window.
2.  Delete the message.
3.  It takes about 2-5 seconds for the window to close.



It does not take this long to delete messages when using version 3.1.  Also, I think it might only be HTML messages that take this long.  Plain text messages appear to delete and the window closes much quicker.
Can you reproduce this issue in safe-mode? ( see how-to start TB in safe-mode here http://support.mozillamessaging.com/bg/kb/Safe+Mode )

Do you have antivirus enabled? Can you try with antivirus disabled?
Keywords: perf
(Reporter)

Comment 2

7 years ago
That support document does not pertain to Firefox 4 or Thunderbird 3.3 which changed the way to load in Safe Mode.

Running in safe mode made no difference to the speed.  But, turning off my anti-virus did make a difference.  I guess I need to see if there is a way for me to tweak the anti-virus.

Comment 3

7 years ago
xref https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&list_id=228408&field0-0-0=short_desc&field1-0-2=longdesc&type0-0-1=substring&field0-0-1=keywords&type1-0-1=substring&resolution=INVALID&value1-0-1=antivirus&type1-0-2=substring&value1-0-2=antivirus&query_format=advanced&value1-0-0=antivirus&value0-0-1=perf&type0-0-0=substring&value0-0-0=slow%20&field1-0-0=status_whiteboard&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Whiteboard: [support][antivirus]
(Reporter)

Comment 4

7 years ago
I am running Microsoft Security Essentials for my anti-virus.  I have removed the following directories from scanning and it does appear to be faster, but still not as fast as version 3.1.  Also, I do not like not having these directories scanned.

c:\program files (x86)\miramar
c:\users\jeff\appdata\local\thunderbird\profiles
c:\users\jeff\appdata\roaming\thunderbird

Comment 5

7 years ago
I am not aware of any performance regressions between TB3.1 and 3.3. So I suspect this is something unique to your environment.

I don't think you should be excluding (x86)\miramar - that's not a profile directory

Do you have other spyware or firewall software?

see also 
bug 621083 comment 8
http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird
https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems
Whiteboard: [support][antivirus] → [support][antivirus: MSE]
You need to log in before you can comment on or make changes to this bug.