CORS for canvas (drawImage and texImage2D)

RESOLVED DUPLICATE of bug 682299

Status

()

Core
ImageLib
--
enhancement
RESOLVED DUPLICATE of bug 682299
7 years ago
6 years ago

People

(Reporter: James Darpinian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.57 Safari/534.24
Build Identifier: 

Cross-Origin Resource Sharing should allow drawing cross-domain image/video elements into canvas 2D and WebGL contexts without tainting the origin-clean state of the canvas (so toDataURL/getImageData/readPixels still work).

http://www.w3.org/TR/cors/#use-cases

Reproducible: Always
Imagelib would need to store this data and expose it...
Component: Canvas: WebGL → ImageLib
QA Contact: canvas.webgl → imagelib
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

7 years ago
I'm seeing this with Firefox 5.0

Sending this HTTP header when returning the image resource from the other domain does not help:
  Access-Control-Allow-Origin: *

I still get a:
  uncaught exception: [Exception... "Failure arg 5 [nsIDOMWebGLRenderingContext.texImage2D]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"

Comment 3

6 years ago
I'm told that Access-Control-Allow-Origin header is ignored and to fix this issue, CORS attribute needs to be implemented. More information in tickets #682299 and #692677.
Actually, looks like this bug is now fixed for <img>.  For <video>, it's a duplicate of bug 682299.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 682299
You need to log in before you can comment on or make changes to this bug.