Closed Bug 655863 Opened 10 years ago Closed 10 years ago

Port |Bug 581475 - nsContextMenu cleanup|

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.2

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

A certain amount of clean up was done in Bug 581475 for Firefox and Bug 425575 fixed an issue to do with large context menus.
This patch ports those fixes across to SM.
Attachment #531179 - Flags: review?(neil)
I could never reproduce the STR for bug 425575...
I can reproduce Bug 425575 with SeaMonkey 2.0 but not with SeaMonkey 2.1pre or  Firefox 4.0.2pre. I assume that some backend change (probably the mouse handling code) fixed this without needing the front end wallpaper.
Firefox 4 has the workaround from bug 425575.
(In reply to comment #2)
> I can reproduce Bug 425575 with SeaMonkey 2.0 but not with SeaMonkey 2.1pre
> or  Firefox 4.0.2pre. I assume that some backend change (probably the mouse
> handling code) fixed this without needing the front end wallpaper.

Having done some further testing, bug 425575 only seems to exist on SM2.0 under Windows, other platforms on SM2.0 don't have the bug and SM2.1 doesn't have the bug at all. I'll respin without that part in the patch.
Summary: Port |Bug 425575 - Huge context menu when holding right-click on a page, dragging mouse and letting go anywhere out of content area| and |Bug 581475 - nsContextMenu cleanup| → Port |Bug 581475 - nsContextMenu cleanup|
Blocks: 566214
Attachment #531179 - Flags: review?(neil)
Changes since v1.0:
* Removes the fix from bug 425575 as it does not appear to be needed against moz-2.0 and above.
Attachment #531179 - Attachment is obsolete: true
Attachment #531454 - Flags: review?(neil)
No longer depends on: 425575
Comment on attachment 531454 [details] [diff] [review]
Port the one set of fixes patch v1.1 [Checked in: Comment 7]

>+    if (aNode.namespaceURI == xulNS ||
>+        this.isTargetAFormControl(aNode)) {
Please update the comment for this function to match.
Attachment #531454 - Flags: review?(neil) → review+
Comment on attachment 531454 [details] [diff] [review]
Port the one set of fixes patch v1.1 [Checked in: Comment 7]

http://hg.mozilla.org/comm-central/rev/910bed11ccfc
Attachment #531454 - Attachment description: Port the one set of fixes patch v1.1 → Port the one set of fixes patch v1.1 [Checked in: Comment 7]
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.2a1
Blocks: 660501
Depends on: 687186
No longer depends on: 687186
You need to log in before you can comment on or make changes to this bug.