Last Comment Bug 655869 - Permissions tab assumes all consumers use testPermission
: Permissions tab assumes all consumers use testPermission
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Page Info Window (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 9
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-09 16:11 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2011-09-14 12:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.38 KB, patch)
2011-09-06 13:52 PDT, :Margaret Leibovic
gavin.sharp: review+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-09 16:11:43 PDT
... and the geolocation API doesn't.

STR:
1) Go to http://gavinsharp.com/tmp/geo.html
2) Select "Never Share" from the doorhanger dropdown
3) Go to http://www.gavinsharp.com/tmp/geo.html
4) Open page info, go to the "Permissions" tab

Expected: the "Share Location" row should have "Always Ask" selected (the geo prompt did show up after 3)

Actual: the "Share Location" row shows "Block", since it thinks the gavinsharp.com permission applies to www.gavinsharp.com (due to using testPermission)
Comment 1 :Margaret Leibovic 2011-09-06 13:52:51 PDT
Created attachment 558594 [details] [diff] [review]
patch
Comment 3 :Margaret Leibovic 2011-09-14 12:16:35 PDT
https://hg.mozilla.org/mozilla-central/rev/d287051139f4

Note You need to log in before you can comment on or make changes to this bug.