TI: Assertion failure: v.isNumber() || v.isBoolean(), at js/src/jsobj.cpp:6598

RESOLVED DUPLICATE of bug 655998

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 655998
7 years ago
7 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The following testcase asserts on TI revision 32e8c937a409 (run with -m -n -a),
tested on 64 bit:

function TestCase(n, d, e, a) {}
function writeHeaderToLog( string ) { print( string ); }
var SECTION = "9.4-1";
var TITLE   = "ToInteger";
writeHeaderToLog( SECTION + " "+ TITLE);
new TestCase( SECTION,  "td = new Date(-Math.PI);td.valueOf()", -3,  eval("td = new Date(-Math.PI);td.valueOf()"));
new TestCase( function(SECTION) { this.TestCase=SECTION; this.Number++; }() );
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655998
(Reporter)

Updated

7 years ago
Blocks: 676763
You need to log in before you can comment on or make changes to this bug.