Unifying the file system

RESOLVED DUPLICATE of bug 655973

Status

--
enhancement
RESOLVED DUPLICATE of bug 655973
8 years ago
8 years ago

People

(Reporter: mongolie2006-firefox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110424 Thunderbird/3.1.10

Every user has a file system. Moreover there are many hidden files such as, in Linux, the very important .thunderbird containing the mails of a user of Thunderbird, and .mozilla, containing his bookmarks. I don't mind very much where automatically created technical files are stored, but, as far as files for humans are concerned, I don't like at all the idea of having in one place all the the mails, in an other place all the bookmarks, in a 3rd place all the remaining information I need etc.. This reminds me the 19th century books main classification in libraries: high books, medium-sized books, small books. The topic classification was only a secondary criteria (inside the "high books", all high books of maths were together, but small books of maths were elsewhere). In modern libraries, such a technical classification has been replaced by a more functional one, so that all books of algebra are together, whatever be their size. The same way, I don't like having similar parallel hierarchies in my documents, in my e-mails, my bookmarks etc. I'd like to have in a one directory called providers/graphists/Naranbolor/ all the files concerning the graphist called Naranbolor, whether these are pictures, bills, tariff spreadsheets, quotations documents, e-mails or the bookmark to her website, rather than a folder in Thunderbird for her mails, a bookmark called "Naranbolor" in a folder providers/graphists in Firefox, and a third folder Documents/ providers/graphists/Naranbolor/ in my file hierarchy. The same way LibreOffice opens when I double-click on an ODF document, Inkscape opens when I double-click on a SVG document, gedit opens when I double-click a text document etc., Thunderbird would open when I click on a mail.

I think giving priority to functional classification on technical one would be a major improvement in personal computer software design, including in cloud design.

Reproducible: Always

Steps to Reproduce:
1.Get the need to classify functionally your information.
2.You have to create similar folders in your bookmarks manager, your file system, and in Thunderbird.

Actual Results:  
After you've done this job, you still cannot see together in one place the mails, the bookmarks and the other files regarding a given topic.


Expected Results:  
Getting in one folder (whether a technical folder or a virtual one does matter) all the information concerning any given topic, including mails, no matter the form of the information.

See bug #655973 regarding Mozilla.
No need to have two bug reports.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655973
You need to log in before you can comment on or make changes to this bug.