Error "Unexpected server error while validating" when uploading a new version

RESOLVED DUPLICATE of bug 654232

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
RESOLVED DUPLICATE of bug 654232
7 years ago
2 years ago

People

(Reporter: Ryan Li, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110509 Firefox/6.0a1
Build Identifier: 

I've attempted to update my extension for numerous times but always got this error: "Unexpected server error while validating."
I have tried Firefox and Chromium but always the same result.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 531305 [details]
The XPI file that caused the error

Whenever I try to upload this package the error message is shown when validating.

Comment 2

7 years ago
Traceback (most recent call last): 
File "/data/amo_python/www/prod/zamboni/apps/devhub/tasks.py", line 27, in validator result = _validator(upload.path) 
File "/data/amo_python/www/prod/zamboni/apps/devhub/tasks.py", line 70, in _validator spidermonkey=settings.SPIDERMONKEY) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/validate.py", line 39, in validate for_appversions=for_appversions) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/submain.py", line 54, in prepare_package for_appversions) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/submain.py", line 122, in test_package return test_inner_package(err, package_contents, package, for_appversions) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/submain.py", line 239, in test_inner_package test_func(err, package_contents, xpi_package) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/testcases/content.py", line 130, in test_packed_packages sub_xpi) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/submain.py", line 239, in test_inner_package test_func(err, package_contents, xpi_package) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/testcases/content.py", line 160, in test_packed_packages data["extension"]) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/testcases/markup/markuptester.py", line 101, in process self._feed_parser(line) 
File "/data/amo_python/www/prod/zamboni/vendor/src/amo-validator/validator/testcases/markup/markuptester.py", line 107, in _feed_parser self.feed(line + "\n") 
File "/usr/lib/python2.6/HTMLParser.py", line 108, in feed self.goahead(0) 
File "/usr/lib/python2.6/HTMLParser.py", line 148, in goahead k = self.parse_starttag(i) 
File "/usr/lib/python2.6/HTMLParser.py", line 249, in parse_starttag attrvalue = self.unescape(attrvalue) 
File "/usr/lib/python2.6/HTMLParser.py", line 387, in unescape return re.sub(r"&(#?[xX]?(?:[0-9a-fA-F]+|\w{1,8}));", replaceEntities, s) 
File "/usr/lib/python2.6/re.py", line 151, in sub return _compile(pattern, 0).sub(repl, string, count) 
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 6: ordinal not in range(128)

Comment 3

7 years ago
Ryan, this bug is already fixed and will be pushed to production this Thursday. please try uploading on Friday and let us know it worked. Thanks and sorry for the inconvenience.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 654232
(Reporter)

Comment 4

7 years ago
Thanks, it's resolved now.
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.