Last Comment Bug 655997 - Crash when changing the orientation from portrait to landscape or vice versa
: Crash when changing the orientation from portrait to landscape or vice versa
Status: VERIFIED FIXED
[has patch]
: crash, regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: P1 blocker (vote)
: Firefox 6
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
: 656291 (view as bug list)
Depends on:
Blocks: 643032
  Show dependency treegraph
 
Reported: 2011-05-10 06:01 PDT by Andreea Pod
Modified: 2011-07-14 22:21 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
crash message (236.72 KB, image/png)
2011-05-10 06:01 PDT, Andreea Pod
no flags Details
crash log (31.31 KB, text/plain)
2011-05-10 06:02 PDT, Andreea Pod
no flags Details
Null pointer crash log (3.08 KB, text/plain)
2011-05-10 06:27 PDT, Aaron Train [:aaronmt]
no flags Details
patch (2.07 KB, patch)
2011-05-10 07:37 PDT, Matt Brubeck (:mbrubeck)
blassey.bugs: review+
Details | Diff | Splinter Review

Description Andreea Pod 2011-05-10 06:01:36 PDT
Created attachment 531308 [details]
crash message

Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/201105010 Firefox/6.0a1 Fennec/6.0a1 
Device: LG Optimus 2X (Android 2.2)

Steps to reproduce:
1. Open Fennec 
2. Change the orientation

Expected result:
The application should work with no problem

Actual result:
Fennec crashes "The application Fennec(process org.mozilla.fennec) has stopped unexpectedly. Please try again."

Note: 
You can see the attached screenshot and log.
Comment 1 Andreea Pod 2011-05-10 06:02:39 PDT
Created attachment 531309 [details]
crash log
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-10 06:18:26 PDT
(In reply to comment #1)
> Created attachment 531309 [details]
> crash log

I don't see a crash in the log. Does the crash happen for other phones too?
Comment 3 Aaron Train [:aaronmt] 2011-05-10 06:20:58 PDT
Able to reproduce with same build, Nexus One

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dfcfa00eb188&tochange=e0f6db50231f
Comment 4 Aaron Train [:aaronmt] 2011-05-10 06:25:31 PDT
05-10 09:23:43.070: ERROR/AndroidRuntime(4485): java.lang.RuntimeException: Unable to resume activity {org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.NullPointerException
Comment 5 Aaron Train [:aaronmt] 2011-05-10 06:27:00 PDT
Created attachment 531313 [details]
Null pointer crash log
Comment 7 Aaron Train [:aaronmt] 2011-05-10 06:38:30 PDT
No idea why a rotation triggers this, weird
Comment 8 Matt Brubeck (:mbrubeck) 2011-05-10 07:37:29 PDT
Created attachment 531326 [details] [diff] [review]
patch

Oops, we need to move the initialization *above* the early return in onCreate, so it's re-created whenever the activity is.
Comment 9 Matt Brubeck (:mbrubeck) 2011-05-10 09:18:23 PDT
http://hg.mozilla.org/mozilla-central/rev/24bd5f86695c
Comment 10 Aaron Train [:aaronmt] 2011-05-11 06:04:51 PDT
Verified fixed:
Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110511 Firefox/6.0a1 Fennec/6.0a1
Comment 11 Ludovic Hirlimann [:Usul] 2011-05-11 07:33:24 PDT
*** Bug 656291 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.