Java reads manual proxies even when preference set to direct

VERIFIED DUPLICATE of bug 48336

Status

VERIFIED DUPLICATE of bug 48336
18 years ago
14 years ago

People

(Reporter: dlg, Assigned: matt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I go to preferences->proxies.
I set manual prox configuration for http and ssl to an arbitrary host and port
(without a real proxy). I then select direct connection to internet on the same
screen. I press ok. Normal browsing works, however java applets attempt to read
through the proxy.(as in during the loading of classes they search through the
proxy instead of directly to the net.

 If I go back and remove the manual setting proxies and the restart mozilla, it
returns to working condition. I am using Build 2001011508 however I initially
discovered this behavior with Java 0.7 (I only figured out what was causing it
today because it was inheriting the defunct configuration from my netscape 4.7
installation (which handles this properly...) 
(oh by the way this build of mozilla is really excellent. You guys are damned
close.)

Comment 1

18 years ago
Reporter : First, thanks for the compliments, and for using Mozilla :-)
Related bug entries are bug 48336 and bug 48430. Could you please view each of
those? I think this is a dup of bug 48336, however I need your confirmation.
Thank you alot,
Fabian.

Comment 2

18 years ago
From reporter :
"This looks exactly correct. It is a duplicate of the bug. I did search but it
is sometimes hard to find a match. In any case, I guess I am just confirming the
bug is still open at 200101150"
Marking as such.

*** This bug has been marked as a duplicate of 48336 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified dup of bug 48336
"Proxy default settings in JAVA plugin use wrong browser sets"
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.