If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

assertions when typing in composer

VERIFIED FIXED in mozilla0.9.1

Status

()

Core
Editor
P2
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: blizzard, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build on Jan 16, 2001.

Bring up the composer window and type.  I'm seeing assertions like this:

###!!! ASSERTION: bad action nesting!: 'mActionNesting>0', file ../../../mozilla
/editor/base/nsHTMLEditRules.cpp, line 292
###!!! Break: at file ../../../mozilla/editor/base/nsHTMLEditRules.cpp, line 292
###!!! ASSERTION: bad action nesting!: 'mActionNesting>0', file ../../../mozilla
/editor/base/nsHTMLEditRules.cpp, line 292
###!!! Break: at file ../../../mozilla/editor/base/nsHTMLEditRules.cpp, line 292
###!!! ASSERTION: bad action nesting!: 'mActionNesting>0', file ../../../mozilla
/editor/base/nsHTMLEditRules.cpp, line 292

If I'm typing in a table the letters never show up at all.  Might be related,
might not.

Comment 1

17 years ago
assigning to akkana since this is a linux bug, akkana can you take a look?
Assignee: beppe → akkana

Comment 2

17 years ago
I'm not seeing this with my Jan 16 build.  I run: mozilla -edit, or run mozilla
then click on the editor button on the taskbar, and when the window comes up I
start typing random stuff, and I see no assertions.  I click the table icon on
the toolbar, click ok in the dialog, and start typing random stuff, and the
characters go into the first table cell correctly (still no assertions).

Need help in reproducing this: what am I missing?  I used a debug build pulled
around 1/16 around 11am.
(Reporter)

Comment 3

17 years ago
Here's what I'm using for my build.  I still get this on a brand new build on
Jan 17.

../mozilla/configure  --disable-mailnews --enable-nspr-autoconf
--disable-jar-packaging

Comment 4

17 years ago
I suppose the --disable-mailnews or the --disable-jar-packaging might have
something to do with it.

It's not clear whether this is linux only or not, it may be a function of
turning off mailnews or jars.

Joe, can you take a look at this? I have no clue what that assert means or what
the code around it does.  Bump it back to me if you need to, but please add a
comment about how the action nesting works so I have some idea how to proceed. 
Meanwhile, I can try to make a build with those flags.
Assignee: akkana → jfrancis
(Assignee)

Comment 5

17 years ago
that assert should be pretty darn impossible.  Something is fuxed.  What would 
help me diagnose more than anything esle is a stack trace.  Can someone who can 
reproduce this set a breakpoint and get a stack trace?  You may need to modify 
the code into a normal if clause in order to have a line to set the breakpoint on 
- I'm unfamiliar with unix debuggers.
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 6

17 years ago
moving a bunch of 0.9 bugs to 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 7

17 years ago
this is a dup of a bug that byner recently fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
verified in 2/7 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.