Last Comment Bug 656041 - Some parts of page scroll at different rates in Fennec
: Some parts of page scroll at different rates in Fennec
Status: VERIFIED FIXED
: mobile, regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Benjamin Stover (:stechz)
:
: Milan Sreckovic [:milan]
Mentors:
: 656416 659891 (view as bug list)
Depends on: 647192
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 09:45 PDT by Matt Brubeck (:mbrubeck)
Modified: 2011-07-20 08:22 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
-
fixed
fixed
6+


Attachments
Some parts of page scroll at different rates in Fennec (3.25 KB, patch)
2011-05-10 15:55 PDT, Benjamin Stover (:stechz)
roc: review+
bugzilla: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image Matt Brubeck (:mbrubeck) 2011-05-10 09:45:00 PDT
1. Open http://tbpl.mozilla.org/?tree=Firefox in Fennec and wait for it to finish loading.
2. Scroll the page.

Results: In my Android opt build, some parts of the content scroll normally, while others stay fixed at first and then "catch up" with the others after a delay.  (On another page where I saw this, the text scrolled normally but backgrounds lagged behind.)

In my desktop Linux debug build, I get a content process crash:

###!!! ABORT: nsDisplayScrollLayer should always be defined: 'hasCount', file /home/mbrubeck/src/mozilla/mozilla-central/layout/base/nsDisplayList.cpp, line 1938
Comment 1 User image Benjamin Stover (:stechz) 2011-05-10 15:37:42 PDT
Thanks to Roc for helping me find this problem. When sets are finally merged into a stacking context, there is a particular expected ordering. First come borders and backgrounds, then negative z-index, etc. See:

http://mxr.mozilla.org/mozilla-central/source/layout/generic/nsFrame.cpp#1542

Since I was putting the info display item in Content(), it was possible for scroll layers to be put below info layers, which violates an important invariant!
Comment 2 User image Benjamin Stover (:stechz) 2011-05-10 15:55:13 PDT
Created attachment 531483 [details] [diff] [review]
Some parts of page scroll at different rates in Fennec
Comment 3 User image Benjamin Stover (:stechz) 2011-05-10 15:58:12 PDT
Try build started here: http://tbpl.mozilla.org/?tree=Try&rev=50815fe4496e
Comment 4 User image Martijn Wargers [:mwargers] 2011-05-10 16:01:50 PDT
Is this a regression from bug 647192? In that case it should block that bug.
Comment 5 User image Benjamin Stover (:stechz) 2011-05-10 16:03:02 PDT
Not a regression, but the reftest relies on the added displayport stuff from bug 647192.
Comment 6 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-10 16:43:40 PDT
Comment on attachment 531483 [details] [diff] [review]
Some parts of page scroll at different rates in Fennec

Review of attachment 531483 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 7 User image Benjamin Stover (:stechz) 2011-05-11 12:33:21 PDT
*** Bug 656416 has been marked as a duplicate of this bug. ***
Comment 8 User image Benjamin Stover (:stechz) 2011-05-24 11:40:15 PDT
*** Bug 658315 has been marked as a duplicate of this bug. ***
Comment 9 User image Kevin Brosnan [:kbrosnan] 2011-05-26 10:42:15 PDT
*** Bug 659891 has been marked as a duplicate of this bug. ***
Comment 10 User image Matt Brubeck (:mbrubeck) 2011-06-01 21:26:59 PDT
Is this ready to land on mozilla-central?   Is it safe to request approval to land this in Aurora for Firefox 6?
Comment 11 User image Matt Brubeck (:mbrubeck) 2011-06-01 21:32:00 PDT
Requesting tracking-firefox6.  This is a user-visible regression from Fennec 5 to Fennec 6.
Comment 12 User image Benjamin Stover (:stechz) 2011-06-02 09:26:47 PDT
Sorry, this went off my radar. This needs another try run. I was having reftest issues but I think the FF5 regression fix might have taken care of the orange.
Comment 13 User image Benjamin Stover (:stechz) 2011-06-02 10:36:12 PDT
Still seems to have an orange, sadly: http://tbpl.mozilla.org/?tree=Try&rev=af7f094914ab
Comment 14 User image Benjamin Stover (:stechz) 2011-06-14 09:27:24 PDT
Fixed reftest for orange by disabling reftest for non-remote run.

Pushed to inbound http://hg.mozilla.org/integration/mozilla-inbound/rev/c64dcd99b27e
Comment 15 User image Matt Brubeck (:mbrubeck) 2011-06-15 10:02:34 PDT
http://hg.mozilla.org/mozilla-central/rev/c64dcd99b27e
Comment 16 User image Matt Brubeck (:mbrubeck) 2011-06-22 07:29:39 PDT
Comment on attachment 531483 [details] [diff] [review]
Some parts of page scroll at different rates in Fennec

Requesting approval-mozilla-aurora.  One-line change to fix a regression from Fx5 -> Fx6 that breaks some web pages in Fennec.  This patch has been in nightlies for the past week with no adverse effect on desktop or mobile.
Comment 17 User image Johnathan Nightingale [:johnath] 2011-06-22 11:57:20 PDT
(In reply to comment #16)
> Comment on attachment 531483 [details] [diff] [review] [review]
> Some parts of page scroll at different rates in Fennec
> 
> Requesting approval-mozilla-aurora.  One-line change to fix a regression
> from Fx5 -> Fx6 that breaks some web pages in Fennec.  This patch has been
> in nightlies for the past week with no adverse effect on desktop or mobile.

(Aside: this is basically the perfect nomination comment)
Comment 19 User image Andreea Pod 2011-06-30 01:41:20 PDT
I can still reproduce this issue following steps from bug 656041 which is duplicate of this, on Aurora build:
Mozilla /5.0 (Android;Linux armv7l;rv:6.0a2) Gecko/20110629 Firefox/6.0a2 Fennec/6.0a2
device: LG Optimus 2X (Android 2.2)
Comment 20 User image Andreea Pod 2011-06-30 01:42:36 PDT
Bug 658315, sorry.
Comment 21 User image Andreea Pod 2011-07-14 04:59:46 PDT
Still reproducible on Firefox 6 Beta 2: 
Mozilla /5.0 (Android;Linux armv7l;rv:6.0) Gecko/20110713 Firefox/6.0 Fennec/6.0 
following the steps from bug 658315. Reopening.
Comment 22 User image Benjamin Stover (:stechz) 2011-07-14 15:07:23 PDT
Part of the problem of bug 658315 was fixed by this bug, but looking at the screenshot for bug 658315 shows that 658315 is not a duplicate of this bug. This is my error; I just saw the crash stack and assumed that it was the same problem.

Closing this bug and re-opening the dupe.
Comment 23 User image Andreea Pod 2011-07-20 08:22:41 PDT
Verified fixed on Firefox 6 Beta 2: Mozilla /5.0 (Android;Linux armv7l;rv:6.0) Gecko/20110713 Firefox/6.0 Fennec/6.0

Device: LG Optimus 2X (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.