Closed Bug 656055 Opened 13 years ago Closed 13 years ago

Configure fails to properly parse registry settings for DirectX-SDK path under Windows/XP

Categories

(Firefox Build System :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 643732

People

(Reporter: wgianopoulos, Assigned: wgianopoulos)

Details

Attachments

(1 file)

Attached patch fixSplinter Review
Evidently, 'reg query' under Windows/XP uses TABs as delimiters.  The code in configure to parse the installpath for the DirectX-SDK assumes it will be one or more spaces.
Attachment #531370 - Flags: review?(ted.mielczarek)
Summary: Configure fails to properly parse regisstry settings for DirectX-SDK path under Windows/XP → Configure fails to properly parse registry settings for DirectX-SDK path under Windows/XP
Status: NEW → ASSIGNED
dupe of bug 643732. I would be very interested in knowing whether the patch in bug 648804 fixes it, as it makes it no longer rely on spaces-vs-tabs.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
(In reply to comment #1)
> dupe of bug 643732. I would be very interested in knowing whether the patch
> in bug 648804 fixes it, as it makes it no longer rely on spaces-vs-tab

It will probably take me until the weekend to have time to test this, but I will be happy to do so.
Oh -- didn't see that you attached a patch here. Sorry.

But we need the patch in bug 648804 anyway. Can you try it?

Of course both patches can be merged. If the patch in bug 648804 doesn't fix the issue on WinXP, one can merge the regex from your patch into it.
(In reply to comment #3)
> Oh -- didn't see that you attached a patch here. Sorry.
> 
> But we need the patch in bug 648804 anyway. Can you try it?
> 
> Of course both patches can be merged. If the patch in bug 648804 doesn't fix
> the issue on WinXP, one can merge the regex from your patch into it.

This was really a very simpleminded replace all TABs with spaces before doing the other substitution for multiple spaces to a single space etc.
On the other hand my patch looks for the first occurence of [a-zA-Z]:\ and interprete that as the beginning of the path.

I'm happy with anything that works.
Attachment #531370 - Flags: review?(ted.mielczarek)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: