Last Comment Bug 656059 - Remove TraceRecorder::getClassPrototype(JSProtoKey, LIns*&), replace with TR::getObjectPrototype(LIns*&) and similar
: Remove TraceRecorder::getClassPrototype(JSProtoKey, LIns*&), replace with TR:...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 10:48 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-10-20 03:06 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add operator-> to DebugOnly<T> (489 bytes, patch)
2011-05-10 10:49 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
cjones.bugs: review+
Details | Diff | Review
Ask for specific prototypes, not for a prototype specified key-wise (7.81 KB, patch)
2011-05-10 10:50 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
jorendorff: review+
Details | Diff | Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-10 10:48:31 PDT
If you want a class prototype, you should ask for it specifically.  Asking specifically gives us more freedom in how we store prototypes (and constructors, for now) in the global object, and it's cleaner and more readable than having to know what a |key| variable could be when it's used in a centralized method.

There are a few different methods for getting an original prototype in use in jstracer.cpp; this bug will fix the one that accepts a JSProtoKey to determine what prototype to get.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-10 10:49:38 PDT
Created attachment 531374 [details] [diff] [review]
Add operator-> to DebugOnly<T>

It turns out that DebugOnly<T> isn't so hot when T is a pointer type right now.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-10 10:50:30 PDT
Created attachment 531375 [details] [diff] [review]
Ask for specific prototypes, not for a prototype specified key-wise
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-18 14:19:50 PDT
http://hg.mozilla.org/tracemonkey/rev/c2315c604e7c for DebugOnly<T>::operator->, but the main patch here still remains to be reviewed/committed.
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-05-23 14:14:21 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/c2315c604e7c
Note: not marking as fixed because fixed-in-tracemonkey is not present on the whiteboard.
Comment 5 Jason Orendorff [:jorendorff] 2011-07-01 10:58:53 PDT
Comment on attachment 531375 [details] [diff] [review]
Ask for specific prototypes, not for a prototype specified key-wise

Sure, ok.
Comment 6 Jeff Walden [:Waldo] (remove +bmo to email) 2011-10-19 14:12:17 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d5e6ea418eea
Comment 7 Jeff Walden [:Waldo] (remove +bmo to email) 2011-10-19 14:31:06 PDT
And this, to fix compiler warnings that gcc 4.6.1 is apparently smart enough (or conservative enough) to not emit:

https://hg.mozilla.org/integration/mozilla-inbound/rev/e13c356c0a45

Note You need to log in before you can comment on or make changes to this bug.