Regression on Bug 620931 causing sites to hang.

RESOLVED FIXED

Status

defect
P1
critical
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110510 Firefox/6.0a1
Build Identifier: Build ID: 20110510130319

Example sites that hang Fx6:

http://wikidrivers.com/wiki/Main_Page
http://www.weather.com/

Regression Range:

Good: mozilla-central: changeset 69244:8d378453a8ac
Bad:  mozilla-central: changeset 69251:83ca7e971857

No hangs when I set 'dom.ipc.plugins.enabled' to false.

Reproducible: Always
Reporter

Updated

8 years ago
Keywords: regression
Version: unspecified → Trunk
Blocks: 620931
Reporter

Updated

8 years ago
Priority: -- → P1
Confirming and setting to NEW

See comments https://bugzilla.mozilla.org/show_bug.cgi?id=620931#c59 and following for more info about the hangs and a WinDbg trace filed by Alice...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 656174
Dang people are fast, first filed a dupe at the same time and then cannot dupe against.. since it got marked before I could do it..  :)

anyway.. flash sites take down the whole browser, have to kill Firefox.
Interestingly enough, I don't see the hang on the same hourly builds here on my computer.

Comment 5

8 years ago
Just backed out parts 3-7. Not everyone is seeing this bug but I don't want to find out the hard way how many people do see it.

http://hg.mozilla.org/mozilla-central/rev/2ab5c696884e
http://hg.mozilla.org/mozilla-central/rev/f442ce8fb412
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Reporter

Comment 7

8 years ago
(In reply to comment #6)
> Can people seeing these freezes test these builds:
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mh@glandium.org-
> 3d08dc03ef77/try-win32/
> 
> Thanks

Still getting hangs.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110510 Firefox/6.0a1 - Build ID: 20110510230021
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.