Changing div from display:none to normal doesn't work with overflow:auto and width small enough

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: ruairif, Assigned: pierre)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Okay, difficult to describe this one, even more difficult to decide where it 
should go.
I have a document which has two css boxes side by side: the left one acts as a 
menu. Clicking on a highlighted word within this menu causes a previously 
hidden DIV block in the right box to become visible. I want to set the overflow 
of the right box to auto. However, when I do this, clicking on any option in 
left hand box does nothing. 
Thorough trial and error, I have found that if I remove the width setting for 
the right hand box then it all works again. The right hand box widens to the 
size of the screen and the correct DIV is displayed. Reducing the width value 
causes the display to work intermittently, and with rendering glitches. IE5 
dispalys everything correctly.
I will try and simplify this down and post an attachment, in a little while.

I'm using build 2001011520 on WindowsNT
A testcase would be great.  If you have the page on a public server somewhere,
could post a url for now so that others could also try to testcase this?

Thanks for using Mozilla and reporting bugs!
(Reporter)

Comment 2

18 years ago
I'll have a URL to show this in a about 2 weeks. I'm having a few major 
problems using overflow, positioning of relative elements, etc. that are 
blocking some of the work I'm doing.Unfortunately, I don't have time at the 
moment to file bug reports for all these to a sufficiently high standard. So, 
it'd be easier just to post a URL that demonstrates as many bugs as possible. 
Is it appropraite to notify the person in charge of scripting engine/CSS 
development, about this link? 

Comment 3

18 years ago
Please keep in mind that most of those positioning are already filed, please
check for duplicates before reporting any of those additional bugs you are seeing.
Adding hixie to CC in case he knows of this problem already.
Still would like a test case.
(Reporter)

Comment 4

18 years ago
I'll try and post a testcase soon. I can't upload through my college proxy, so 
I can't post testcases until I can get to my home computer, which isn't very 
often. Unfortunately, this means I have about 3 or 4 bugs that I'm supposed to 
post testcases for and can't. However, I'll try and make one up over the 
weekend, if I can.
Cormac, any luck on that testcase?
(Reporter)

Comment 6

18 years ago
As luck would have it, I'm heading home today for the weekend, where I can 
upload files at last. So, I'll try and find the time to do a testcase and post 
it here. I'd certainly like to see this fixed - its one of the (few) bugs thats 
blocking the stuff I'm doing
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 8

18 years ago
Cromac: ANy luck on those testcases?

Comment 9

18 years ago
Marking INVALID due to lack of testcase or reproducibility. Reopen when we have
either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

18 years ago
Sorry, haven't had time to make a testcase - blame my impending exams!
verified. reopen the bug when you have testcases -- thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.