Firefox "tabs on top" breaks Windows 7 UI

RESOLVED DUPLICATE of bug 624129

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 624129
7 years ago
7 years ago

People

(Reporter: steven.george, Unassigned)

Tracking

4.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

The Firefox "tabs on top" feature breaks some Windows 7 UI functionality.  

When Firefox is maximised in Windows 7, and you have tabs on top, and there are mutiple tabs spanning the entire width of the screen, there is no way to grab the title bar in order to move (and unmaximize/restore) the window.

Windows 7 allows you to grab the title bar of maximised windows; a feature that did not exist in XP (or Vista I believe).

I like this feature of Windows 7, and Firefox breaks it for me.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 4 in Windows 7.
2. Maximise Firefox
3. Open sever tabs; enough to span the entire width of the screen
4. Try to move the window by dragging the title bar.

Actual Results:  
Note you can't drag the window via its title bar.  All the title bar space is obscured by tabs.

Expected Results:  
It should respect the Windows 7 UI functionality, which allows dragging of maximised windows.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

7 years ago
This was addressed in bug 624129. There's an empty space added before the minimize button to accommodate areo snap.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624129

Comment 2

7 years ago
Note that bug 624129 has been WRONGLY tagged as resolved & fixed, someone should reverse this. The bug was ..."isn't easy draggable" a bit space was added, and still people land on that bug when wanting to report the same, or report dupes like this.

Someone did a real BAD job here...

Comment 3

7 years ago
The plan if you check the comments from the ui theme is that tearing should be disabled in fullscreen mode and this effect should be for the entire tab strip. But that's not possible right now. Donno if there's bug is on file, but its whats meant to happen. That bug was for 4.0 and it is what will happen in 4.x a better fix will be in ff6 or ff7.
You need to log in before you can comment on or make changes to this bug.