Last Comment Bug 656253 - intermittent failure in /tests/content/base/test/test_XHR.html | hello pass
: intermittent failure in /tests/content/base/test/test_XHR.html | hello pass
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 722962
Blocks: 438871 649133
  Show dependency treegraph
 
Reported: 2011-05-11 04:53 PDT by Marco Bonardo [::mak]
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.26 KB, patch)
2011-05-11 05:14 PDT, Masatoshi Kimura [:emk]
jonas: review+
Details | Diff | Review

Description Marco Bonardo [::mak] 2011-05-11 04:53:32 PDT
this started after the fix in bug 649133 that added a part to the test.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305109212.1305110129.5236.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/05/11 03:20:12


5365 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | wrong blob size - 11 should equal 11
5366 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | responseXML should be null. - null should equal null
5367 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | responseText should be empty string. - "" should equal ""
5368 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | response should be empty string. - "" should equal ""
5369 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | status should be 0. - 0 should equal 0
5370 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | statusText should be empty string. - "" should equal ""
5371 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | getAllResponseHeaders() should return empty string. - "" should equal ""
5372 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | wrong status - 200 should equal 200
5373 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | should have a non-null blob
5374 INFO TEST-PASS | /tests/content/base/test/test_XHR.html | wrong blob size - 12 should equal 12
5375 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
 - wrong values
Comment 1 Masatoshi Kimura [:emk] 2011-05-11 05:14:46 PDT
Created attachment 531588 [details] [diff] [review]
patch

Two |fr| shouldn't interfere each other because the execution order is unpredictable.
Comment 2 Jonas Sicking (:sicking) 2011-05-11 11:03:31 PDT
Comment on attachment 531588 [details] [diff] [review]
patch

Thanks for being on this so quickly!
Comment 3 Jonas Sicking (:sicking) 2011-05-11 11:12:51 PDT
Checked in

http://hg.mozilla.org/mozilla-central/rev/dfb70d26874e
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-06-30 10:02:15 PDT
Calling this fixed.
Comment 5 Treeherder Robot 2012-01-31 05:43:21 PST
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=8972541&tree=Firefox
Rev3 WINNT 5.1 mozilla-central opt test mochitests-1/5 on 2012-01-31 05:03:58

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass

Note You need to log in before you can comment on or make changes to this bug.