first incomplete addon submission, then submission impossible due to "name already in use"

VERIFIED FIXED in 6.1.0

Status

addons.mozilla.org Graveyard
Developer Pages
P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: Jan Schnitzler, Assigned: jbalogh)

Tracking

unspecified
6.1.0
x86_64
Windows 7

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I did a test submission with an addon my company developed, but did not finish it. (Name: picpasso@sdzinvest.de, uploading account: SDZ or ogopode)
Later I wanted to submit the addon, but after passing the auto-validation, the process stops and tells me that the name is already in use. When I search my addons, I cannot find the addon with this name and therefore cannot delete it or share ownership.

Reproducible: Always

Steps to Reproduce:
1.upload of the addon
2.wait for auto-validation
3.click on continue

Actual Results:  
I get the message: This addon name is already in use. Please choose another one.

Expected Results:  
The submission progress should have continued normally.

Updated

7 years ago
Component: Developer Tools → Developer Pages
Product: Firefox → addons.mozilla.org
QA Contact: developer.tools → developers
(Assignee)

Comment 1

7 years ago
What is the name and guid (<em:id>) of the add-on you're trying to submit?
(Reporter)

Comment 2

7 years ago
The Name is PicPasso and the (<em:id>) is picpasso@sdzinvest.de
(Assignee)

Comment 3

7 years ago
I don't see that em:id in our database and PicPicasso isn't in our list of taken names. Can you try again? If you still have trouble, please attach your .xpi to this bug.
(Reporter)

Comment 4

7 years ago
Created attachment 531916 [details]
The addon I tried to submit.
(Reporter)

Comment 5

7 years ago
I attached the addon to the bug after I tried to submit the file again, but got the same notification.
(Reporter)

Comment 6

7 years ago
I tried to upload the addon again today, but I still get the same message. Is there anything else I can do? Is there some admin I could contact?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 6.0.12
Your install.rdf has no <em:name>.  I suspect it's coming through as blank, and triggering the error.
(Reporter)

Comment 8

7 years ago
OK, I will talk to the developer about that. Thanks a lot!!!
(Reporter)

Comment 9

7 years ago
I talked to the developer and checked the install.rdf myself, there is a <em:name> in it. The value is "PicPasso". It is located at the end of the file, under the comment "Front End MetaData".
So is there anything else that could cause the message?
(Reporter)

Comment 10

7 years ago
(In reply to comment #3)
> I don't see that em:id in our database and PicPicasso isn't in our list of
> taken names. Can you try again? If you still have trouble, please attach
> your .xpi to this bug.

I just saw that you checked for the name PicPicasso instead of PicPasso. Maybe this name is in the database?

Thanks for all the help so far...
I wasn't able to reproduce this on my dev copy, I'm not sure what is going on.  Jeff:  I don't even see the "INFO UPLOAD" in the logs, which comes before any validation I thought.  Other uploads are happening without a problem, so it's something to do with either the .xpi or something in our db related to the xpi.
Assignee: nobody → jbalogh
Priority: -- → P2
Target Milestone: 6.0.12 → 6.1.0
(Reporter)

Comment 12

7 years ago
Is there anything else I could do to contribute to solving the problem? My boss is starting to worry about the submission to the addons-site...
(Assignee)

Comment 13

7 years ago
(In reply to comment #10)
> (In reply to comment #3)
> > I don't see that em:id in our database and PicPicasso isn't in our list of
> > taken names. Can you try again? If you still have trouble, please attach
> > your .xpi to this bug.
> 
> I just saw that you checked for the name PicPicasso instead of PicPasso.
> Maybe this name is in the database?
> 
> Thanks for all the help so far...

PicPasso was in our list of taken names, so I removed it. Can you try again?
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

7 years ago
I just uploaded the addon again and could finish the submission process without problems. Thanks a lot!
Verified fixed based on comment #14.
Status: RESOLVED → VERIFIED

Comment 16

6 years ago
We have exactly the same problem with our extension named Adlesse (uploaded from account "Adlesse")

We did a test submission with early version of Adlesse some time ago and than disable it. With this test submission we has some troubles (see https://bugzilla.mozilla.org/show_bug.cgi?id=641864#c11). After fixing this issue test addon was deleted from my profile.

Now I want to submit the latest version of addon, but after passing the auto-validation, the process stops and tells me that the name is already in use. When I search addons by name, I cannot find the addon with this name and therefore cannot delete it or share ownership.
The add-on exists, and it has an Incomplete status. It is still associated wit the "Adlesse" account, so you should be able to upload a new version using that account, or transfer ownership to somebody else. If you're seeing any problems, please email amo-admins AT mozilla DOT org.

Comment 18

6 years ago
The problem is that I can't see old incomplete version of add-on in "My add-ons" under Adlesse account.
Please send a message to the email address given above. This is a closed bug and this discussion belongs somewhere else.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.