Deleted message reappears in inbox, even if trash has been emptied

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
MailNews: Message Display
P1
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Erich 'Ricky' Iseli, Assigned: Navin Gupta)

Tracking

Trunk
mozilla0.9

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+] fix in hand)

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
This is a very strange thing happening. I got a spam message (will attach it)
which does reappear in the inbox from time to time, even if I deleted it and
emptied the trash. This behavior is only happening with this message, this is
why I suspect this message to have something odd...

happening with 20010109 build on Windows 98
(Reporter)

Comment 1

18 years ago
Created attachment 22688 [details]
Culprit message saved as .eml from the trash

Updated

18 years ago
QA Contact: esther → sheelar
(Reporter)

Comment 2

18 years ago
s/often/randomly/ in Summary
Summary: Deleted message always reappears in inbox, even if trash has been emptied → Deleted message randomly reappears in inbox, even if trash has been emptied

Comment 3

18 years ago
Moved and deleted mail randomly appearing in folders. I inspected the
folders(mozilla/users50/...) and the mail does still exist in the FILE file.
Note:sometimes is does actually delete the mail but not usually. Even with mail
still in FILE file doesn't always show up in Mail Front End.

Comment 4

18 years ago
Moved and deleted mail randomly appearing in folders. I inspected the
folders(mozilla/users50/...) and the mail does still exist in the FILE file.
Note:sometimes is does actually delete the mail but not usually. Even with mail
still in FILE file doesn't always show up in Mail Front End.

Comment 5

18 years ago
Created attachment 22729 [details]
Inbox mail(no special cases,happens with any mail)that randomly pops up, none showing now.
(Reporter)

Comment 6

18 years ago
Found out that it does not _randomly_ reappear. It appears _always_ when Mozilla
rebuilds the folder contents. Changing Summary accordingly
Summary: Deleted message randomly reappears in inbox, even if trash has been emptied → Deleted message reappears in inbox, even if trash has been emptied

Comment 7

18 years ago
*** Bug 67081 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
I thought this was going to be because the X-Mozilla-Status header was missing,
but it's present. There are two X-UIDL headers, which is weird, though I don't
know why it would cause this problem.

Comment 9

18 years ago
This also applies to Linux. I'm using build 20010129.
Could this have to do something with the "Compact This Folder" problem (bug
#63804)? Because I compacted my (pop3) local folders after deleting mails, and
sometimes later those deleted mails reappeared.

Comment 10

18 years ago
Using 2001020504 on W2K
Using a POP account, I saw messages from the past week reappear in my inbox.
Some of them had been deleted and trash emptied, some moved to other folders (so
now I had 2 copies of them). At the same time the nstmp-folder appeared. 
Next time this happens I hope I can provide more detail. 

Comment 11

18 years ago
This is pretty serious.  Maybe it should be nominated at a 0.8 stopper?  That'd 
be pretty bad if there was no way to delete email in a milestone release.  I 
get highvolume mail and right now I have accumulated 400 messages in my inbox 
over the last few days.  Thanks!

Comment 12

18 years ago
Stopper? It hasn't stopped any previous releases. This bug's been around a long
time. When compacting Inbox, nstemp is created (containing just the messages you
intended to keep) but does not overwrite the Inbox file; thus, nstemp appears
upon next startup as a new folder and all your messages _reappear_ in Inbox. To
workaround, I manually delete Inbox and Inbox.msf and rename nstemp as Inbox.
(Reporter)

Comment 13

18 years ago
mojazz, I don't know if it is a stopper or not, but today I ended with over 200
messages in my inbox when yesterday I had only 10. But 200 messages I had filed
in another folder or deleted were just back again. This is a major loss of
function since the inbox is meant to store _new_ mail and the filed/deleted
messages should no longer be there.
Severity: normal → major

Comment 14

17 years ago
It's not only a problem with "Inbox". It's a problem with every folder. I think
the problem is even more serious with "Unsent Messages" as mail gets sent again
and again if you don't check the folder whether mails reappeared or not.

Comment 15

17 years ago
All/All
OS: other → All
Hardware: PC → All

Comment 16

17 years ago
*** Bug 68481 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
Is this bug the reason it takes 30 seconds before message content is displayed?

Comment 18

17 years ago
*** Bug 68837 has been marked as a duplicate of this bug. ***
over to naving. 

naving writes:

"I am having problems with compaction of pop inbox folder. Most of the times it
is not able to delete the old inbox file and so the "nstmp" cannot be renamed to
new inbox. This is not happening with inbox.msf. It also happens with compaction
of only inbox folder. 

This may be serious because if you shut down mail client and bring it up again,
then nstmp shows up as a new folder. Also the old inbox is still getting used."
Assignee: sspitzer → naving
(Assignee)

Comment 20

17 years ago
A similar bug has been marked for mozilla 0.9 so we will be working on it.

Comment 21

17 years ago
It sounds like 68875 might be dup of this. Since this bug has more info in it
let's keep this one.
Keywords: nsbeta1
Priority: -- → P1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9

Comment 22

17 years ago
There are two issues here. One is the regression in "compact this folder" and
the other is the years-old bug that causes deleted messages to reappear every
time the summary is rebuilt...

These two bugs just happen to form a nasty combination that makes it impossible
to get rid of things completely. When "compact this folder" was finally fixed
not long ago (before this current regression), I was finally able to eradicate
messages that I had left over from the day that NS6.0PR1 came out.

Surely there's already a low-numbered bugzilla entry for this one?

Comment 23

17 years ago
I'm drowning in mail that is undeleting itself. Is there a work around? This is
making mail almost unusable for me. I went from 50 messages to 213 overnight.
(Assignee)

Updated

17 years ago
Blocks: 67468
(Assignee)

Comment 24

17 years ago
Created attachment 25756 [details] [diff] [review]
part of the fix with message reappearing in trash. Other part of the fix is in #68875

Comment 25

17 years ago
I already posted a way around this bug in bug 67468.  I'll paste it here: 

>> I'm having the same problem.  The only way I've found to fix it is to select
all of the messages I want to keep, move them to a temporary mail folder, quit
Mozilla and delete my inbox folder, then rename the temporary folder to the
inbox folder and start Mozilla again.

I've also noticed that my inbox.msf file is always zero bytes. <<
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta1+] → [nsbeta1+] fix in hand
(Assignee)

Comment 26

17 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 27

17 years ago
Which part got fixed? The compact regression or the undeleting of messages that
haven't been compacted out yet? or were both fixed?
(Assignee)

Comment 28

17 years ago
Both parts were fixed.

Comment 29

17 years ago
Hallelujah!  (just deleted 100+ Inbox messages that decided to come back from
the dead.)

Comment 30

17 years ago
Navin checked in fix for this problem today. Please try this on tomorrow's build
just to make sure.  
(Assignee)

Comment 31

17 years ago
Please verify only for deleted messages reappearing in inbox. 
#68875 takes care of the compact issue. 

Comment 32

17 years ago
This hit me today again :(

I was using a cvs trunk build, which was built around was 3 hours ago.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 33

17 years ago
Does this take into account deleted messages coming back to life in the Drafts
folder as well?  Between the regurgitation and bug 11387 (multiple copies of
drafts everytime you hit save), you can get a lot of drafts in a hurry. ;)
(Assignee)

Comment 34

17 years ago
Waara, did you compact inbox after delete and then saw the deleted messages in 
inbox. 

Comment 35

17 years ago
No. When I have to empty the trash I just do "Empty Trash".
(Assignee)

Comment 36

17 years ago
So "Empty Trash" causes messages to reappear in inbox. ?

Comment 37

17 years ago
I don't think so. I didn't do empty trash before it happened, I'm just saying
that I don't use Compact folder at all.

I have no idea what's causing this.. sorry.

Comment 38

17 years ago
I am using windows build 2001030205 and I am still experiencing the problem with
deleted mail reappearing in the inbox. 

This has happened a few times for me, each time everything from the trash was
sent to my inbox marked as new unread email. This happens when starting mozilla
mail, not after deleting email or when I empty the deleted email folder. 

At one point I thought this may be caused by the ammount of deleted emails,
since the first time I had about 100 deleted emails. This has happened with both
small and large ammounts of deleted email, so I don't think it really has
anything at all to do with the ammount of deleted email. I don't use the compact
folders feature at all.  Could the problem of reappearing deleted email be a
result of not compacting folders? 

I have decided to have mozilla empty my deleted email folder when I exit the
program, since the problem occures when mozilla mail is started. This should
make the program more usable until the problem is solved.

Comment 39

17 years ago
I have problems that seem to be the same (two) bugs, but in a different situation:

I send my mails via Send Later and the Unsent Messages folder. After doing a
Sent Unsent Messages, the messages are deleted in the Unsent Messages folder,
and appear in the Sent folder. After quitting and restarting Mozilla, there's a
good chance that these messages reappear in the Unsent Messages folder. Also
even older messages keep reappearing.

However, I found a workaround for my problem. After sending the messages, I do a
Compact on the (empty) Unsent Messages folder. In the special case of an empty
folder, Compact seems to work fine.

(still using moz0.8)
(Assignee)

Comment 40

17 years ago
Created attachment 26804 [details] [diff] [review]
proposed fix. Need review

Comment 41

17 years ago
A little comment about the code surrounding the last diff:

I think when you want to test if a pointer is null or not, you should check
against nsnull, not NULL.
(Assignee)

Comment 42

17 years ago
Created attachment 26817 [details] [diff] [review]
revised patch

Comment 43

17 years ago
sr=bienvenu, Hakan is right about nsnull.
(Assignee)

Comment 44

17 years ago
fix checked in
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 45

17 years ago
*** Bug 71205 has been marked as a duplicate of this bug. ***

Comment 46

17 years ago
*** Bug 71293 has been marked as a duplicate of this bug. ***

Comment 47

17 years ago
*** Bug 71425 has been marked as a duplicate of this bug. ***

Comment 48

17 years ago
*** Bug 72015 has been marked as a duplicate of this bug. ***

Comment 49

17 years ago
verified,
2001-03-12-09-win98
2001-03-08-10-linux
2001-03-08-10-linux

Based on comments from naving on 2001-02-27 11:08 I verified this bug is on imap 
and pop accounts that deleted messages are not reappearing in the inbox after 
emptying the trash and also after you exit the application and open again these 
deleted messages do not reappear in the inbox.  Any other bugs in the event of 
fixing this bug please open a new bug. This is not fixing any compact folder 
issues.
Status: RESOLVED → VERIFIED

Comment 50

17 years ago
*** Bug 77325 has been marked as a duplicate of this bug. ***

Comment 51

17 years ago
*** Bug 77531 has been marked as a duplicate of this bug. ***

Comment 52

16 years ago
Still occuring in Mozilla 0.9.8 build 2002021203

Comment 53

15 years ago
Given that bug 202094 was just reported, this may very well be a more recent
regression.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.