If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Automatically close plugin-container processes via timeout period after tab using content within the container is closed

RESOLVED DUPLICATE of bug 501485

Status

()

Core
IPC
--
enhancement
RESOLVED DUPLICATE of bug 501485
7 years ago
7 years ago

People

(Reporter: Danial Horton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0a2) Gecko/20110510 Firefox/5.0a2
Build Identifier: 

Some plugins are only used by specific sites but continue running for ever after leaving the site/closing the tab, OoP should utilise a timeout period to close plugin processes that have not been used for some time and have no active content running in any tabs.

This would minimise the behavior of certain plugin leaks.  I myself noticed the flash container utilising around 320MB's of memory whilst no tabs had an applet running earlier, having the container process closed after a period of time would reduce such occurences

Reproducible: Always


Actual Results:  
container continues running for ever

Expected Results:  
container processes are managed appropriately to ensure resources are managed properly.
Dup of bug 501485?
(Reporter)

Comment 2

7 years ago
ah, yeah it would seem so, i didn't use specific enough search queries to spot that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501485
You need to log in before you can comment on or make changes to this bug.