Sync Setup error dialog appears when bypassing easy setup

VERIFIED FIXED in Firefox 6

Status

Fennec Graveyard
General
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: tchung, Assigned: mbrubeck)

Tracking

({regression})

Trunk
Firefox 6
ARM
Android
regression

Details

(Whiteboard: [has patch])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 531664 [details]
cannot setup sync screenshot

The Cannot Setup Sync error dialog appears immediately if bypassing easy setup code.   See screenshot

Repro:
1) install android nightly build on phone or tablet: Mozilla/5.0 (Android; Linux armv71; rv:6.0a1) Gecko/20110511 Firefox/6.0a1 Fennec/6.0a1
2) Prefs > Sync > Click Connect (assuming no account setup yet)
3) Easy setup dialog appears.  wait for code to show
4) Click "I'm not near my computer..." link
5) Verify Cannot setup dialog pops up immediately, then asking user to try again.

Expected:
- Cannot setup sync dialog shoudlnt appear since user didnt change anything yet

Actual:
- error dialog popup
(Assignee)

Updated

6 years ago
tracking-fennec: --- → ?
(Assignee)

Comment 1

6 years ago
Can't reproduce this in Aurora (Firefox 5).
status-firefox5: --- → unaffected
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

6 years ago
Regression from bug 649739.
Blocks: 649739
Keywords: regressionwindow-wanted
(Assignee)

Comment 3

6 years ago
Created attachment 532381 [details] [diff] [review]
patch

The JPAKE client code now sends "jpake.error.userabort" instead of (null) when the user cancels the connection process.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #532381 - Flags: review?(mark.finkle)
(Assignee)

Updated

6 years ago
Whiteboard: [has patch]
(Assignee)

Updated

6 years ago
Flags: in-testsuite?
Attachment #532381 - Flags: review?(mark.finkle) → review+
tracking-fennec: ? → 6+
(Assignee)

Comment 4

6 years ago
http://hg.mozilla.org/mozilla-central/rev/5b483355806f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Target Milestone: --- → Firefox 6
(Reporter)

Comment 5

6 years ago
Verified fix on nightly: Mozilla/5.0 (Android; Linux armv71; rv:6.0a1) Gecko/20110516 Firefox/6.0a1 Fennec/6.0a1
Status: RESOLVED → VERIFIED
status-firefox6: --- → fixed
(Assignee)

Updated

5 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.