Implement new Mobile Dashboard

VERIFIED FIXED in 4.1

Status

Input Graveyard
Frontend
VERIFIED FIXED
7 years ago
a year ago

People

(Reporter: davedash, Assigned: tofumatt)

Tracking

unspecified
x86
Mac OS X

Details

Implement the new designs for the Mobile Dashboard:

http://chowse.github.com/voxpop-mobile-prototype/

The code naturally is available via Github, but you'll be responsible for the CSS/JS so if you cut and paste, be sure to stand behind the code :)

I'm setting this to 4.1, since during much of 4.0 you will be onboarded as a Mozilla Webdev and getting used to the process.  If you manage to get this bug done in 4.0 we'll ship it.
(Assignee)

Updated

7 years ago
Component: Input → Frontend
Product: Webtools → Input
Version: Trunk → unspecified
(Assignee)

Comment 1

7 years ago
So I've been hacking away on this and it's given me a pretty good sense of how Input is put together. This was definitely a sweet first bug/feature to hack on for this project (so thanks for that Dave).

Anywho, here's a GitHub compare view for my bug branch compared to master: https://github.com/tofumatt/reporter/compare/master...bug-656380-mobile-dashboard

I haven't pulled in some recent changes from master, but there shouldn't actually be any conflicts relating to the mobile stuff. I figured I should just do that merging when I bring this back into master, but if you'd rather I did it now and posted another compare view that's no prob.

Sooooo... r?
(Assignee)

Updated

7 years ago
Duplicate of this bug: 598095
(Assignee)

Comment 3

7 years ago
As of this commit the dashboard is mobilized! https://github.com/fwenzel/reporter/commit/bbe1e2658784858ba038807006296b58a2ec2d45

r+ from davedash. Ready for some fun QA. I tested it in a desktop browser, iOS (iPhone 4 & Simulator), and on a real Nexus S, but let me know if it's wonky on any other device.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
This is looking quite good. FYI QA is waiting to mark VERIFIED after a few more test cycles encase any missed implementation points peculate up between now and the push bug 663452.
Nothing new has bubbled out as bugs with the new mobile layout. QA verified... ship it!
Status: RESOLVED → VERIFIED
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.