POP3 account setup fixes login name incorrectly

RESOLVED DUPLICATE of bug 212937

Status

--
major
RESOLVED DUPLICATE of bug 212937
18 years ago
10 years ago

People

(Reporter: autophile, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
After setting up a new POP3 account, mailnews will attempt to log into the POP3
server using a login name created from the given user name and server name. For
example, with a user name of "autophile" and a server name of
"pop.starband.net", mailnews will attempt to log into the server with a login
name of "autophile@pop.starband.net".

However, some POP3 servers (notably starband.net) require the login name to be
of the form "autophile@starband.net", and NOT "autophile@pop.starband.net", and
there is no apparent way to get mailnews to change its default behavior. The
result is that mailnews cannot log in to the mail server.

Updated

18 years ago
QA Contact: esther → sheelar

Comment 1

18 years ago
Marking NEW. This seems really stupid from starband.net, why do they have to do
it differently from the others, and annoy us with that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

18 years ago
Oh horrors! The POP3 server in JAMES (java.apache.org/james) requires that the
USER name exactly match the name the POP3 administrator put in. For example, if
the administrator put "autophile" in as a name, then the USER parameter must be
"autophile", and nothing else. Although it's easy to see in the JAMES code where
you can first strip off anything after a "@" in the USER parameter.

I've checked out some other POP3 servers by experimentation, and they seem to
allow anything, even garbage after the "@", e.g. "autophile@giggles".

Nevertheless, there are now at least two POP3 servers out there requiring an
exact USER parameter -- JAMES, and whatever starband.net uses.

Suggestion: In registering the account with mailnews, if the username contains a
"@" then use that full username, else append the servername to it. So if I
register my username as "autophile@starband.net" it will send that as the USER
parameter. If I register my username as "autophile", it will send
"autophile@pop.starband.net".

Comment 3

17 years ago
Is this bug a duplicate of bug 108387 (or vice versa)?

Updated

16 years ago
QA Contact: sheelar → esther

Comment 4

16 years ago
Starband.net is not the only ISP out there with this problem. Verizon (only a
100,000s DSL users) uses the servers incoming.verizon.net and outgoing.verizon.net.
If your email adress and login name is user.name@verizon.net you are really SOL
because mozilla mail forces the login to be user.name@incoming.verizon.net,
which does not work very well to log in to the server.
Granted, I'm a newbie on Linux (installed RH 8.0 last week), but unless I'm
missing something, this affects many users....
mass re-assign.
Assignee: naving → sspitzer

Comment 6

16 years ago
webhost4life.com also has this problem for domains hosted on their servers. 
The login name must be of the form "account@yourdomain.com". I am unable to 
use Mozilla Mail to access my email there because there is no way to specify 
the account name it will use for the POP3 "USER" login command.

Comment 7

16 years ago
Just as  comment #6 said, there are many ISP that have this problem (I know at
least two in Austria) when you have your own domain. The same problem, btw,
occurs with SMTP.

I have to connect to the server smtp.myprovider.com and supply a login name
(SMTP login) myaccount.myowndomain.org. This does not work with Mozilla,
unfortunatly.

Simply bug/feature, but quite an impact!

Comment 8

15 years ago
I have exactly the same problem with 2 "freemailers" using Thunderbird. However
Mozilla 1.4 rc2 performs ok (under Windows). I'm using Konquerer under Linux and
no problems with the same email accounts.
I'd welcome a quick fix, POP3 servers won't change to suit us!

Comment 9

15 years ago
I have the same problem with a Onetel DSL connection in the UK on both Mozilla
1.4.1 & 1.5 in both Linux and WindowsXP. It a pretty major flaw for someone
whose trying to migrate from Micro$oft products to Open Source stuff Like Linux
and Mozilla

Comment 10

15 years ago
*** Bug 222761 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
Jamie, as Joe infla in bug 222761, comment #1 already noted we have a patch in
bug 212937 for this.
It's in the trunk since about a month now. Please anybody check this issue with
a recent trunk build and comment if this "problem"* still persists.

*I'm still convinced there's not really such problem as the string
"name@domain@domain" displayed in the dialogues has nothing to do with the real
username sent to the server.
something sounds really wrong.

if my username is foo and I'm at pop.bar.com, we should be logging in with the
username of foo.
christian, I just checked with a recent trunk win32 build, and I think this
problem is fixed.

is it a dup of bug #212937, that you fixed?

Comment 14

15 years ago
Yes, Seth, it really looks like a dupe. But I wanted to be sure that Mozilla is
sending a wrong login name is only in the peoples head.
If somebody had an evidence it would be no dupe.

*** This bug has been marked as a duplicate of 212937 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.