The default bug view has changed. See this FAQ.

<div id="content"> climbs over the field, firerfox incorrectly calculates the width of the block

RESOLVED DUPLICATE of bug 243412

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 243412
6 years ago
6 years ago

People

(Reporter: Artem, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

incorrectly calculates the width of the block <div id="content">


Reproducible: Always

Comment 1

6 years ago
The width of #content is 20px + 100% + 20px because of the padding.

This will work if and when -moz-box-sizing loses its -moz- prefix.

If it is your site you could change

#top,#top2,#content,#footer,#mainwrap,#main
 {box-sizing                                 : border-box;}

in user.css to

#top,#top2,#content,#footer,#mainwrap,#main
 {box-sizing                                 : border-box;
  -moz-box-sizing : border-box;}

as is done elsewhere in the stylesheets. Discussion on dropping prefix in in bug 243412

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243412

Comment 3

6 years ago
In this case it doesn't make a difference, but in general the un-prefixed property should be the last one:

#top,#top2,#content,#footer,#mainwrap,#main
 { -moz-box-sizing: border-box;  box-sizing: border-box; }

If you have no influence on Opera blog stylesheets, you should report this to Opera and referring to this bug report.
You need to log in before you can comment on or make changes to this bug.