Install simplejson on win32 dev slaves

RESOLVED DUPLICATE of bug 682408

Status

P3
normal
RESOLVED DUPLICATE of bug 682408
7 years ago
5 years ago

People

(Reporter: rail, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [staging][buildslaves][opsi])

(Reporter)

Description

7 years ago
on w32-ix-slave08:

python e:/builds/moz2_slave/try-w32/tools/buildfarm/utils/hgtool.py http://hg.mozilla.org/try build
...
Traceback (most recent call last):
  File "e:/builds/moz2_slave/try-w32/tools/buildfarm/utils/hgtool.py", line 60, in <module>
    import simplejson as json
ImportError: No module named simplejson

Probably we'll also need to updated the ref image(s)?

Comment 1

7 years ago
From the code it appears that this is running on a non-2.6 python - are we not going to have other problems besides this import if we install the package and it continues to run past that point?

Is this the bug that makes us move things to 2.6?

Updated

7 years ago
Whiteboard: [staging][buildslaves] → [staging][buildslaves][opsi]
Priority: -- → P3
pretty sure this is included with the buildbot opsi package
I just got a purple on my m-c push which used w32-ix-slave07, which seems to be a similar complaint about lack of simplejson when trying to post stuff to graph server.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307573643.1307579262.28178.gz&fulltext=1
(In reply to comment #3)
> I just got a purple on my m-c push which used w32-ix-slave07

Reopened bug 661758.
The offending slaves are disabled, and I'll be double-checking the entire w32-ix-slaveNN fleet before turning any others on.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
w32-ix-slave26 seems to have been reenabled prematurely ? https://bugzilla.mozilla.org/show_bug.cgi?id=663025#c3

Comment 7

7 years ago
We will be setting this and many more w32 ix machines (hopefully correctly) in bug 682408.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 682408
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.