bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox 4.0.1 doesn't save Manual proxy configuration after closing Firefox 4.0.1

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: whoamomma2, Unassigned, NeedInfo)

Tracking

4.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

This started happening when i updated Firefox 4.o to Firefox 4.0.1. So i would assume, this bug only happened in Firefox 4.0.1. Anyways,i type in my school's proxy in the manual proxy configuration and port (HTTP Proxy and all proxy protocols). After surfing on the web i decided to close Firefox 4.0.1 and 5 mins later, i wanted to surf on the web again so i opened Fireofx 4.0.1. For 30 mins, i couldn't connect to my schools internet so i checked the manual proxy configuration and i found that, all the HTTP proxy, port and protocals are empty? I was wondering why it was cleared since i already typed in the proxy and port, and assumed it should be saved after closing. Reason why i assumed it should save because the previous Firefox version, like version 4.0, 3.6.13 and other previous version saved the proxy, port and protocals after closing Firefox 4.0.1. Basically, Firefox 4.0.1 doesn't save proxy, protocals and ports after closing it.

Reproducible: Always

Steps to Reproduce:
1.Type in proxy, port and protocals.
2.Press ok for connection settings and press ok for network options.
3.Close the browser and open it again and go back and look at the manual congifuration proxy. Everything is cleared; proxy, ports and protocals.

Actual Results:  
1.Type in proxy, port and protocals.
2.Press ok for connection settings and press ok for network options.
3.Close the browser and open it again and go back and look at the manual congifuration proxy. Everything is cleared; proxy, ports and protocals.

Expected Results:  
All the proxy, ports and protocals are cleared and i have to re type them all back to connect to my shcool internet.

Saved all the proxy, ports and protcals just like the previous Firefox versions.
Is your Issue reproducible without Extensions in Safe-Mode and/or using a new Profile?
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile
Version: unspecified → 4.0 Branch

Comment 2

5 years ago
Are you still able to reproduce this on a more recent version of Firefox?
Flags: needinfo?(whoamomma2)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.