www.alza.cz - right side of web page does not print

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Czech
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Michal 'hramrach' Suchanek, Unassigned)

Tracking

Details

(Whiteboard: [bugday-20110513], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.2; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.2; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

In print preview and printout right side of page is missing.

Reproducible: Always

Steps to Reproduce:
1. go to the above URL
2. select File -> Print Preview


Actual Results:  
Only part of the green button is shown

Expected Results:  
All of page is printed

Scaling the page down in print preview does not help.

Comment 1

7 years ago
This page specified CSS for media="print" as follows.
And all most of parts are display:none. and there are lot of css error.
<link rel="stylesheet" type="text/css" media="print" href="/Css/print-style.css?ver=3" />

So, It seems to be the site issue.
(Reporter)

Comment 2

7 years ago
Opera can print this page just fine.

Also the button is either display:none so it is not shown or it is shown.

In the preview only part of the button is shown so it is not display:none but is not printed fully.

Comment 3

7 years ago
If you mean the 'Pokracovat' button, I can confirm this on linux, it is cut. However, somebody needs to check if it is a problem with Firefox or the site CSS.
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → 2.0 Branch

Updated

7 years ago
Whiteboard: [bugday-20110513]
http://www.alza.cz/Css/print-style.css?ver=3
.table { width:854px }

http://www.alza.cz/Css/alzaM.css?ver=15
.table { overflow:hidden }
.order-toolbar { width:930px }


http://www.alza.cz/Css/o-1.css?ver=4
.order1 { width:930px }

The elements width class "order-toolbar" and "order1" are descendants
of the element with class "table", thus they are clipped.

Not a bug in Firefox.

-> Tech Evang
Assignee: nobody → czech
Component: Print Preview → Czech
OS: Windows Server 2003 → All
Product: Core → Tech Evangelism
QA Contact: printing → czech
Hardware: x86 → All
Summary: right side of web page does not print → www.alza.cz - right side of web page does not print
Version: 2.0 Branch → unspecified
Problem not found
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.