Context menu broken in non-browser sidebars

VERIFIED FIXED in seamonkey2.1final

Status

defect
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

({regression})

Trunk
seamonkey2.1final
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

8 years ago
Steps to reproduce problem:
1. Install a web sidebar
2. Open an editor or compose window, and display the sidebar
3. Right-click in the sidebar

Expected result: context menu

Actual result: menu shows everything and doesn't work.

Comment 1

8 years ago
Perhaps?
http://hg.mozilla.org/comm-central/rev/910bed11ccfc
Bug 655863 - Port |Bug 581475 - nsContextMenu cleanup| r=neil
Assignee

Comment 2

8 years ago
Posted patch Possible patch (obsolete) — Splinter Review
This uses code similar to getNotificationBox() to find the browser.
(Note: this is the global one in navigator.js, not the tabbrowser one.)
The wrappedJSObject isn't needed any more because of the XRayWrapper changes.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #532175 - Flags: review?(iann_bugzilla)

Comment 3

8 years ago
Comment on attachment 532175 [details] [diff] [review]
Possible patch

>+++ b/suite/common/nsContextMenu.js

> nsContextMenu.prototype = {
>   initMenu: function(aBrowser) {
Nit: aBrowser argument could be removed now.

r=me with that addressed

A 2.1 branch version would be good too.
Attachment #532175 - Flags: review?(iann_bugzilla) → review+
Assignee

Comment 4

8 years ago
Attachment #532175 - Attachment is obsolete: true
Attachment #532194 - Flags: review+

Updated

8 years ago
Blocks: 655529
Assignee

Comment 5

8 years ago
Posted patch Branch patchSplinter Review
Assignee

Comment 6

8 years ago
Pushed changeset ffc7c66a1797 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED

Comment 7

8 years ago
Comment on attachment 532197 [details] [diff] [review]
Branch patch

Issue shows up in 2.1 branch for custom/web sidebar tabs.
Attachment #532197 - Flags: review+
Attachment #532197 - Flags: approval-seamonkey2.1?
(In reply to comment #3)
> 
> r=me with that addressed
> 
> A 2.1 branch version would be good too.

Umm, why a 2.1 branch version. Is this enough in itself to make delaying 2.1 necessary with an rc2? Based on my reading I think not.

And I'd rather not land actual code changes on 2.1 without a plan to do a 2.1 update. And the idea of a chemspill here wouldn't warrant a ridealong since we would release off relbranch.

Comment 9

8 years ago
Comment on attachment 532197 [details] [diff] [review]
Branch patch

a=me If we can get this in without giving Callek heartburn.
Attachment #532197 - Flags: approval-seamonkey2.1? → approval-seamonkey2.1+
(In reply to comment #9)
> Comment on attachment 532197 [details] [diff] [review] [review]
> Branch patch
> 
> a=me If we can get this in without giving Callek heartburn.

I'll veto temporarily...

IFF we need to respin, we can take this as a ridealong, failing a respin for another reason I think we need clear reasoning for why this needs to go in, and if its a "we'll respin for this" etc.

We will likely have a release (2.2) within the next month and a half with the rapid release cycle...

Comment 11

8 years ago
Comment on attachment 532197 [details] [diff] [review]
Branch patch

Cancelling approval as per Callek.
Attachment #532197 - Flags: approval-seamonkey2.1+

Comment 12

8 years ago
If it doesn't make it as a ridealong for 2.1 then it will probably need to be relnoted.
Keywords: relnote

Comment 13

8 years ago
Comment on attachment 532197 [details] [diff] [review]
Branch patch

Re-requesting if we're having a respin...
Attachment #532197 - Flags: approval-seamonkey2.1?

Comment 14

8 years ago
Comment on attachment 532197 [details] [diff] [review]
Branch patch

a=me (second time lucky?)
Attachment #532197 - Flags: approval-seamonkey2.1? → approval-seamonkey2.1+

Comment 17

8 years ago
Is this related? DUP?  Related but different?

Bug 104590 - Back in context menu not working correctly when in sidebar
(In reply to comment #17)
> Is this related? DUP?  Related but different?
> 
> Bug 104590 - Back in context menu not working correctly when in sidebar

No (other than being about the sidebar, too, this is about the context menu itself being broken, and that one is about a particular functionality available from the context menu, and is much older).
You need to log in before you can comment on or make changes to this bug.