input type = "image" does not submit name/value

RESOLVED DUPLICATE of bug 619285

Status

()

RESOLVED DUPLICATE of bug 619285
8 years ago
8 years ago

People

(Reporter: kdevel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110513])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110513 Firefox/6.0a1

FF4 does not submit name/value associated with an INPUT element of type "image".

Reproducible: Always

Steps to Reproduce:
1. open testcase
2. submit

Actual Results:  
http://localhost/?name.x=0&name.y=0

Expected Results:  
http://localhost/?name.x=0&name.y=0&name=value (FF <= 3.5, not tested 3.6)
(Reporter)

Comment 1

8 years ago
Created attachment 532282 [details]
testcase image.html
(Reporter)

Updated

8 years ago
Attachment #532282 - Attachment mime type: text/plain → text/html

Comment 2

8 years ago
The test file is referencing a local file that is not accessible from the bugzilla context so it does not show any image. Please update it to use some image from the web by linking it by its full server/path/file .

Updated

8 years ago
Whiteboard: [bugday-20110513]

Comment 3

8 years ago
Created attachment 532327 [details]
HTML file with a working image

Comment 4

8 years ago
I can confirm with both attachments that firefox does not do what the reporter requests.
However, according to the spec at http://www.w3.org/TR/1999/REC-html401-19991224/interact/forms.html#h-17.4.1 it seems there shouldn't be any &name=value string sent to the server. The reported request seems invalid. Can anybody knowledgeable about HTML forms comment?
Component: General → HTML: Form Submission
OS: Linux → All
Product: Firefox → Core
QA Contact: general → form-submission
Hardware: x86_64 → All
Version: unspecified → Trunk
HTML4 is vague to the point of being useless here.  Browser behavior was inconsistent.  HTML5 standardized on the IE behavior here, and we're matching HTML5 on this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 619285
You need to log in before you can comment on or make changes to this bug.