Enhancement Request: In Windows 7, double-clicks on the tab bar when in "tabs on top" mode should open a new tab, not unmaximize the window

RESOLVED DUPLICATE of bug 576807

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 576807
7 years ago
7 years ago

People

(Reporter: Robert Lee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110513])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

(NOTE: This is an enhancement request, not a defect report).

When Firefox is maximized in tabs-on-top mode in windows 7, the tab bar "docks" to the top of the screen, facilitating the use of Fitt's law to enhance usability for certain operations (selecting tabs, closing the window, using the Firefox Menu, etc...). The unoccupied region of the tab bar in this case emulates the window's title bar.

This enhancement request is for the "screen edge" (top-most row of pixels) in the unoccupied region of the tab bar to respond to double-clicks by opening a new tab rather than un-maximizing the window. This would be applicable only when Firefox is maximized when using tabs-on-top mode, and maybe only on Windows 7.

The use case is to enable seasoned users to open new tabs using the method that was available in Firefox 3 (double-clicking the unoccupied region of the tab bar), while not interfering with this region's other purposes in certain platforms (in Windows 7 this region doubles as the title bar, which would respond to double-clicks as clicks on the maximize/restore button).

Reproducible: Always

Steps to Reproduce:
1. Maximize Firefox 4 in Windows 7 with tabs-on-top mode enabled.
2. Double click on the unoccupied region of the tab bar to open a new tab.

Actual Results:  
Windows is restored, no new tab is opened.

Expected Results:  
If the double-click was at the screen edge, a tab should have been opened and the window size should have been unchanged. If the double-click was not at the screen edge, the actual result would be the expected result. (NOTE: This is an enhancement request, not a defect report).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20110513]
Duplicate of bug: 576807
You need to log in before you can comment on or make changes to this bug.