Closing pinned tabs leads to duplicate icons in the group preview [caused by Tab Utilities 1.0.6]

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Simon BOUGET, Unassigned)

Tracking

4.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When I close a pinned tab, the focus goes automatically to the last viewed tab. Then, if I clic on the closed tab, it re-opens. Finally, when I display the "group preview window", the closed-and-reopend pinned tab now has 3 icons instead of 1.

Reproducible: Always

Steps to Reproduce:
1. Close a pinned tab (with CTRL + F4 or right clic, since CTRL + W is disabled for pinned tabs)
2. Clic on the greyed icon representing the now closed tab: it re-opens.
3. Go to the group preview window. Now there are 3 icons for the closed-and-reopend tab on the right sidebar of each group.

Actual Results:  
3 icons

Expected Results:  
1 icon

It isn't related to the number of groups. Since I had also 3 groups opened, I thought it could be, but I have checked that and it's not.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

7 years ago
I can't see any greyed icon representing the closed tab.
Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Is your grey icon located at the same place as the now closed pinned tab was?

Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

7 years ago
No, in safe mode, a pinned tab simply disappear when closed. Yet, when restarting in normal mode, my old list come back, with tabs closed in safe mode greyed but here once again.

I think my only extension interacting specifically with pinned tabs is "Easy App Tabs 3" and the bug is still present after desactivating it/restarting.

Comment 3

7 years ago
How about running in normal mode, but with all add-ons manually disabled?

https://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes#w_test-for-faulty-extensions
(Reporter)

Comment 4

7 years ago
Problem does not occur with all extensions disabled.
Problem occurs with only "Tab Utilities 1.0.6" enabled.

This extension is older than Firefox 4, that's why I didn't realize it could interact. My mistake...

The greyed icons or "phantom tabs" are part of this extension's normal work. But the tripled icon is a bug, i think.

Comment 5

7 years ago
Not a bug in Firefox 4, but in Tab Utilities 1.0.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Summary: closing pinned tabs leads to duplicate icons in group preview → Closing pinned tabs leads to duplicate icons in the group preview if the add-on Tab Utilities 1.0.6 is enabled.
Component: Tabbed Browser → Extension Compatibility
QA Contact: tabbed.browser → extension.compatibility
Summary: Closing pinned tabs leads to duplicate icons in the group preview if the add-on Tab Utilities 1.0.6 is enabled. → Closing pinned tabs leads to duplicate icons in the group preview [caused by Tab Utilities 1.0.6]
You need to log in before you can comment on or make changes to this bug.