Closed Bug 657313 Opened 9 years ago Closed 7 years ago

pluginPath not set on all xpcshell-test invocations

Categories

(Core :: Plug-ins, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: tompelka, Assigned: gfritzsche)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110421 Red Hat/3.6.17-1.el6_0 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110421 Red Hat/3.6.17-1.el6_0 Firefox/3.6.17

TEST-UNEXPECTED-FAIL | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug455213.js | test failed (with xpcshell return code: 0), see following log:

TEST-UNEXPECTED-FAIL | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug471245.js | test failed (with xpcshell return code: 0), see following log:

Reproducible: Always

Steps to Reproduce:
1. compile ff
2. run python -u ./config/pythonpath.py -I./build ./testing/xpcshell/runxpcshelltests.py /usr/lib64/xulrunner-1.9.2/xpcshell /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit from $OBJ_PATH
3.

Actual Results:  
# python -u ./config/pythonpath.py -I./build ./testing/xpcshell/runxpcshelltests.py /usr/lib64/xulrunner-1.9.2/xpcshell /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit
TEST-UNEXPECTED-FAIL | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug455213.js | test failed (with xpcshell return code: 0), see following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/head_plugins.js | [get_test_plugin : 43] true == true
TEST-UNEXPECTED-FAIL | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug455213.js | Plugin library not found - See following stack:
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/testing/xpcshell/head.js :: do_throw :: line 200
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug455213.js :: run_test :: line 99
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/testing/xpcshell/head.js :: _execute_test :: line 128
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test

  <<<<<<<
TEST-UNEXPECTED-FAIL | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug471245.js | test failed (with xpcshell return code: 0), see following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug471245.js | [run_test : 91] true == true
TEST-UNEXPECTED-FAIL | /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug471245.js | true == false - See following stack:
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/testing/xpcshell/head.js :: do_throw :: line 200
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/testing/xpcshell/head.js :: do_check_eq :: line 230
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/testing/xpcshell/head.js :: do_check_false :: line 249
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/_tests/xpcshell/test_plugin/unit/test_bug471245.js :: run_test :: line 97
JS frame :: /root/rpmbuild/BUILD/xulrunner-1.9.2.17/mozilla-1.9.2/testing/xpcshell/head.js :: _execute_test :: line 128
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test

  <<<<<<<
INFO | Result summary:
INFO | Passed: 0
INFO | Failed: 2


Expected Results:  
no failures

appears in 3.6.17
Version: unspecified → 3.6 Branch
I am seeing the same test failures when running the full xpcshell test suite on my local development build - OS X 10.7, mozilla-central trunk
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
Version: 3.6 Branch → Trunk
Also in the same set of tests:

TEST-INFO | /Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell/dom/plugins/test/unit/test_bug813245.js | running test ...
TEST-UNEXPECTED-FAIL | /Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell/dom/plugins/test/unit/test_bug813245.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>

TEST-INFO | (xpcshell/head.js) | test 1 pending

TEST-PASS | /Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell/dom/plugins/test/unit/test_bug813245.js | [run_test : 57] true == true

TEST-UNEXPECTED-FAIL | /Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell/dom/plugins/test/unit/test_bug813245.js | Plugin library not found - See following stack:
JS frame :: /Users/ireid/tbird/mozilla-central/testing/xpcshell/head.js :: do_throw :: line 461
JS frame :: /Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell/dom/plugins/test/unit/test_bug813245.js :: run_test :: line 61
JS frame :: /Users/ireid/tbird/mozilla-central/testing/xpcshell/head.js :: _execute_test :: line 325
JS frame :: -e :: <TOP_LEVEL> :: line 1
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | (xpcshell/head.js) | exiting test
<<<<<<<
Summary: xpcshell-tests failures in test_bug455213.js and test_bug471245.js → xpcshell-tests failures in dom/plugins test_bug455213.js, test_bug471245.js, test_bug813245.js
Strange that this happens in local builds, but apparently isn't seen on TBPL.
Any chance you could check what plugin directories are provided here and wether the test plugin is one of them?
http://dxr.mozilla.org/mozilla-central/dom/plugins/test/unit/head_plugins.js.html#l8
(In reply to Georg Fritzsche [:gfritzsche] from comment #3)
> Strange that this happens in local builds, but apparently isn't seen on TBPL.
> Any chance you could check what plugin directories are provided here and
> wether the test plugin is one of them?
> http://dxr.mozilla.org/mozilla-central/dom/plugins/test/unit/head_plugins.js.
> html#l8

When I run "make xpcshell-tests" from the top level directory, the iterator returned at the cited line returns no values, and the tests fail.

When I run "make -C dom/plugins/test xpcshell-tests" this iterator returns some values, and the tests succeed (diagnosed by putting some dump calls in head_plugins.js to trace the execution of the loop).

Looking at the output from the test runs, the failing make output starts like this:

/Users/ireid/tbird/obj/mozilla-central/_virtualenv/bin/python -u /Users/ireid/tbird/mozilla-central/config/pythonpath.py \
          -I/Users/ireid/tbird/mozilla-central/build -I./_tests/mozbase/mozinfo \
          /Users/ireid/tbird/mozilla-central/testing/xpcshell/runxpcshelltests.py \
          --manifest=./_tests/xpcshell/xpcshell.ini \
          --build-info-json=./mozinfo.json \
          --no-logfiles \
          --tests-root-dir=/Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell \
          --testing-modules-dir=/Users/ireid/tbird/obj/mozilla-central/_tests/modules \
          --xunit-file=/Users/ireid/tbird/obj/mozilla-central/_tests/xpcshell/results.xml \
          --xunit-suite-name=xpcshell \
          --symbols-path=./dist/crashreporter-symbols \
           --logfiles \
          /Users/ireid/tbird/obj/mozilla-central/dist/bin/xpcshell


while the run that succeeds looks like:

/Users/ireid/tbird/obj/mozilla-central/_virtualenv/bin/python -u /Users/ireid/tbird/mozilla-central/config/pythonpath.py \
          -I/Users/ireid/tbird/mozilla-central/build \
      -I../../../_tests/mozbase/mozinfo \
          /Users/ireid/tbird/mozilla-central/testing/xpcshell/runxpcshelltests.py \
          --symbols-path=../../../dist/crashreporter-symbols \
          --build-info-json=../../../mozinfo.json \
          --tests-root-dir=../../../_tests/xpcshell \
          --testing-modules-dir=../../../_tests/modules \
          --xunit-file=../../../_tests/xpcshell/dom/plugins/test/results.xml \
          --xunit-suite-name=xpcshell \
          --test-plugin-path=../../../dist/plugins \
          --logfiles \
          /Users/ireid/tbird/obj/mozilla-central/dist/bin/xpcshell \
          ../../../_tests/xpcshell/dom/plugins/test/unit


Aside from the various relative paths, the most significant difference is that the working run has a "--test-plugin-path=../../../dist/plugins" while the failing run has no such argument to the test harness.

The "full" log of the mozilla-inbound build at https://tbpl.mozilla.org/php/getParsedLog.php?id=19206749&tree=Mozilla-Inbound&full=1 does not appear to record the command line arguments given to xpcshell, so it's hard to tell what's different there.
Blocks: 455213, 471245, 813245
Assignee: nobody → georg.fritzsche
Priority: -- → P2
One more data point. Using the new build script in my mozilla-central source directory,

./mach xpcshell-test

and

./mach xpcshell-test dom/plugins/test/unit

both fail.
 > Aside from the various relative paths, the most significant difference is
> that the working run has a "--test-plugin-path=../../../dist/plugins" while
> the failing run has no such argument to the test harness.

That certainly is the problem, thanks for the details!
Attachment #715546 - Flags: review?(ted) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/4f44d26fa1b0
Status: NEW → ASSIGNED
Summary: xpcshell-tests failures in dom/plugins test_bug455213.js, test_bug471245.js, test_bug813245.js → pluginPath not set on all xpcshell-test invocations
https://hg.mozilla.org/mozilla-central/rev/4f44d26fa1b0
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
You need to log in before you can comment on or make changes to this bug.