Closed Bug 657317 Opened 11 years ago Closed 10 years ago

rewrite guided bug entry

Categories

(bugzilla.mozilla.org :: Extensions, enhancement)

Development
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: glob, Assigned: glob)

References

Details

the guided bug entry form is anything bug friendly to new users of bugzilla, and needs reworking.

at the least it needs to use the new duplicate search, and provide a much bug entry form.
Depends on: 577561
Depends on: 655229
Feedback:

"Add me to the CC list" should be "this is my issue". It would then take you to a screen which said (depending on bug status) either:

"This issue has been fixed in a newer [major/point] release of Firefox; try upgrading"
or
"This issue has been fixed in the development version of Firefox; please wait a few weeks"
or
"This issue is currently being worked on by our engineers. Click here to stay informed of progress"

The text at the top is a bit wordy and hard to act on. How about simply:

"Please fill out this form clearly, precisely and in as much detail as you can manage. Please report only a single problem at a time."

The version field should be pre-populated (for browser products) from the UA, as far as possible.

Can we eliminate the Component field and stick everything in General? We should discuss the pros and cons of that with the QA team. It could be that finding all the misfiled bugs in random components is more effort than it would be to just triage them out of one component.

Other than that, this looks awesome! :-)

Gerv
(In reply to comment #2)
> Can we eliminate the Component field and stick everything in General?

we could; however it may help to know that the general component is always selected by default.
this is enabled on bugzilla-stage-tip:

https://bugzilla-stage-tip.mozilla.org/enter_bug.cgi?format=guided
glob: looking good! :-)

Comments:

* I'd simplify the titles. So just go for:

- Enter A Bug (Step N of 3)

each time. 

* The top of Step 1 should read simply:

I Need Technical Support
I Have An Idea or Suggestion
I Have Other Feedback

None of the above; my bug is in:

<product list>

* Step 2: "Searching for similar issues..." needs an animated GIF throbber. Otherwise it looks like nothing is happening.

* If something goes wrong, it says "Data error". Can we be a bit more friendly? :-)

* If you click "Add me to the CC list", it just says "changes submitted for bug X". Firstly, we should have a message "You have been added to the CC list of <a>bug XXXXXX</a>." Then, ideally, we would have the bug itself below, like after submitting changes directly - although that might be a bit trickier.

* Step 3: I would turn the three sentences at the top back into bullets.

* The component description area needs a title. Also, can we vertically centre the text? At the moment, it's confusingly close to the Version.

* Small nit, but can we fix up the security text box so the description text doesn't come underneath it? You might be able to manage this by setting a large bottom margin or padding on it.

* You have little red stars, presumably to mean "this field is compulsory". But the "alert in your face" method of making people fill out fields is nasty. And the subject will already be filled, the version and component are defaulted. And the rest is phrased as easy-to-answer questions. I don't think "you have to fill this field in with _something_" actually encourages the positive behaviours we want anyway - it just breeds irritation.

So I think we should just remove all compulsion - the stars and the alerts. It simplifies the page and provides a nicer user experience. 

* The headings used in the initial comment for the 3 text boxes don't have to match the questions asked, and they read a bit strangely if they do. I would suggest using:

Steps To Reproduce:

Actual Results:

Expected Results:

And perhaps putting a blank line between each heading and the user's text.

Gervh
(In reply to comment #5)
> * If you click "Add me to the CC list", it just says "changes submitted for
> bug X". Firstly, we should have a message "You have been added to the CC
> list of <a>bug XXXXXX</a>." Then, ideally, we would have the bug itself
> below, like after submitting changes directly - although that might be a bit
> trickier.

You could do a custom format for the bug/process/*.html.tmpl templates but you will need to fix $template->process everywhere in process_bug.cgi and Bugzilla/Bug.pm to honor the format value.

dkl
Isn't there a "message" parameter you can pass to that template which shows up at the top? If so, can you find some hook where you can set it based on a URL parameter you stick in the URL submitted by your button?

Gerv
(In reply to comment #7)
> Isn't there a "message" parameter you can pass to that template which shows
> up at the top? If so, can you find some hook where you can set it based on a
> URL parameter you stick in the URL submitted by your button?

Actually after looking some more, bug/process/header.html.tmpl has the following hook:

[% Hook.process('title') %]

which could be used in this case to show that the users account was added to the cc list of the bug based on the passed parameter.

dkl
Duplicate of this bug: 360650
Couple more things I noticed at least on bugzilla-stage-tip:

1. The favicon does not display properly in the address bar for Firefox when using the guided form. It does display when using the standard enter_bug.cgi form.
2. If you pass in product=SOMEPRODUCT in the URL, it should skip to the dupes search screen. Did we discuss this before and decide to not do this? Can't remember. But if not, I think it would be nice to be able to do so.

dkl
for the CC stuff, i plan on updating the CC list via xhr, rather than redirecting to a new page.  i'll make it so you can only cc yourself from the search results if the bug is open.

(In reply to comment #10)
> 1. The favicon does not display properly in the address bar for Firefox when
> using the guided form. It does display when using the standard enter_bug.cgi
> form.

weird; i'm not touching that and the <link> tag is present.  i'll investigate.

> 2. If you pass in product=SOMEPRODUCT in the URL, it should skip to the
> dupes search screen. Did we discuss this before and decide to not do this?

wasn't discussed, will do :)
(In reply to comment #11)
> weird; i'm not touching that and the <link> tag is present.  i'll
> investigate.

it's a yui history bug; more yui debugging for me :)
A few small bits of feedback -

1. Critically important: people using the guided entry form should not have the component list inflicted on them.  Guided-entry bugs should automatically go into a special triage component.  There should be people whose job - and I mean paid, official job - is to sort those bugs into the proper product and component bins.

2. Choice of product should come before support/feedback/idea screen.  Front-line product list should be trimmed ruthlessly (Firefox / Mobile Firefox / Thunderbird / Other, maybe)

3. The trichotomy "technical support", "feedback", "ideas" doesn't make sense as described - the categories overlap and their tags are not sufficiently memorable.  May I instead suggest something like

  Would you like to tell us about a ...

  Bug: You think [Firefox] is not behaving correctly. Bugs include crashes,
  sluggishness, broken web pages, and loss of data.

  Idea: You think it would be better if [Firefox] did something different
  from what it's doing right now.

where [Firefox] gets replaced with the product selected in the previous step.
If someone can explain to me the difference between "feedback" and "idea" and/or "feedback" and "bug", I'd be happy for it to come back as a third category, but "bug" and "idea" as described above seem like they exhaust the possibilities.

4. Suggest "Please summarize your [bug/idea] in one sentence" instead of "Please provide a short summary of the problem you are having."

5. Do not expose "switch to the advanced bug entry form" on the last screen of the guided form, it's a distraction.  Offer that up front only.
Re Zack's comments:

1. That decision would need to be made by the QA community. Until they make it, we should stick with what we do now.

2. Why do you think the current number is too many? Choosing a product is not like choosing from a restaurant menu. Presumably you know what problem you have. If the most important products are at the top, I think the length of the list isn't a big issue.

3. If we split it as you want, how would we then divide out people who actually want SUMO from those who want Bugzilla?

4, 5: Agreed.

Gerv
(In reply to comment #13)

thanks for the feedback :)

one thing to bear in mind is the guided bug entry form is not the landing page for new users who want to get support or report a bug -- from a bugzilla perspective that's https://bugzilla-stage-tip.mozilla.org/createaccount.cgi

it's for people who have already decided to file a bug, and we should only provide gentle reminders about other options (support, feedback, etc).

> 1. Critically important: people using the guided entry form should not have
> the component list inflicted on them.  Guided-entry bugs should
> automatically go into a special triage component.  There should be people
> whose job - and I mean paid, official job - is to sort those bugs into the
> proper product and component bins.

i agree, however until those components and roles exist we have to display the list.

this wouldn't be practical for a lot of the products, but that's just a matter of only showing the component list if the product is lacking a dedicated triage component.

> 2. Choice of product should come before support/feedback/idea screen.

i'm not sold on this proposal; what's the gain?

> 3. The trichotomy "technical support", "feedback", "ideas" doesn't make
> sense as described - the categories overlap and their tags are not
> sufficiently memorable.
> [...]
> If someone can explain to me the difference between "feedback" and "idea"

feedback is the mechanism for reporting broken websites; we generally don't track them in bugzilla.  it's also the place to provide a quick comment about something that's good or bad in firefox.  neither of these are bugs or ideas.


> 4. Suggest "Please summarize your [bug/idea] in one sentence" instead of
> "Please provide a short summary of the problem you are having."
>
> 5. Do not expose "switch to the advanced bug entry form" on the last screen
> of the guided form, it's a distraction.  Offer that up front only.

nice, will do.
Duplicate of this bug: 577406
Blocks: 662645
Duplicate of this bug: 597631
this is code-complete; i will liaise with IT with regards to making it live on production.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 672191
Component: Extensions: Other → Extensions
You need to log in before you can comment on or make changes to this bug.