Dowloaded files are deleted automatically

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
--
major
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Ulrich Windl, Unassigned)

Tracking

4.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.19) Gecko/20110420 SUSE/2.0.14-0.2.1 SeaMonkey/2.0.14
Build Identifier: 

It's hard to believe, but repeatable: With Firefox 4.0.1 any download of a file immediately "fails" with no specific reason given. When I retry the download (from the Download manager), the download makes normal progress until finished. Firefox reports successful download. But eventually the file is nowhere! If I open the containing folder (via context menu), the folder is empty.
If it weren't myself, I'd say that can't be...

Reproducible: Always

Steps to Reproduce:
1. Download any file


Actual Results:  
Bytes are transferred, but no file is present after download is finished.

Expected Results:  
Either a reasonable error message or explanation, or the downloaded file.
Does setting "browser.download.manager.scanWhenDone" to "false" in "about:config" make a Difference?
Is the Issue independent of the set Target Download Dir?
Version: unspecified → 4.0 Branch

Comment 2

7 years ago
A faulty virus scanner most likely, or I have seen this if I close down firefox in the middle of a virus scan of a download. Something I've been meaning to look into but haven't had the time.
(Reporter)

Comment 3

7 years ago
Different Downlaod directories made no difference. The machine has no virus scanner installed.

Comment 4

7 years ago
(In reply to comment #3)
> Different Downlaod directories made no difference. The machine has no virus
> scanner installed.

In your original post it looks like you were running linux:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.19) Gecko/20110420 SUSE/2.0.14-0.2.1 SeaMonkey/2.0.14

But this bug is marked as an Win XP problem. Which os are you on?
(Reporter)

Comment 5

7 years ago
Believe that what I said more that those information that is automatically submitted: The report was submitted using Linux, but the problem occurred on Windows/XP (as described).
(Reporter)

Comment 6

6 years ago
Created attachment 556509 [details]
Filtered trace for Firefox 6.0 (Windows Process Monitor)

When I upgraded to Fixefox 6.0, the problem is still there. I used Sysinternals' Process Monitor to watch the events (filtered to the file being downloaded). It seems after successful download, Firefox advises Windows to delete the file. I don't quite understand that part, but I'm no Windows programmer. The original file had been compressed for compactness.

Comment 7

6 years ago
(In reply to Ulrich Windl from comment #6)
> Created attachment 556509 [details]
> Filtered trace for Firefox 6.0 (Windows Process Monitor)
> 
> When I upgraded to Fixefox 6.0, the problem is still there. I used
> Sysinternals' Process Monitor to watch the events (filtered to the file
> being downloaded). It seems after successful download, Firefox advises
> Windows to delete the file. I don't quite understand that part, but I'm no
> Windows programmer. The original file had been compressed for compactness.

Do you have a group policy in place on the system that prevent the download of files? If you do you can turn this off.

http://support.mozilla.com/en-US/kb/Unable%20to%20download%20or%20save%20files#w_disable-virus-scanning-in-firefox-preferences
Closing this, but please reopen the bug if you can still reproduce it. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.