Page Unreadable; perhaps due to font sizes or CSS

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: JimJJewett+firefox, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Anything ahead of the sentence fragment "non-profit dedicated to shaping the future of the Web for the public good. " cannot be viewed.  

Similarly, the step 2 box is labeled "KNOW YOUR B"

Reproducible: Always

Steps to Reproduce:
1.  On first launch after upgrade -- also on subsequent launches if that URL is open.
2.  I've included the settings page, just in case.  I don't recall changing anything relevant -- and the tiny fonts on some pages (and in this textbox) suggest I haven't done it universally.
3.



  Application Basics

        Name
        Firefox

        Version
        4.0.1

        User Agent
        Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        ScrapBook
        1.4.4
        true
        {53A03D43-5363-4669-8190-99061B2DEBA5}

        Microsoft .NET Framework Assistant
        1.0
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        IBM Add To Notes Address Book BluePages Plugin
        1.1.2
        true
        bpaddtonab@firefox-extensions.ibm.com

        Reframe It
        2.0.0.20091223
        false
        plugin@reframeit.com

        Firefox Sync
        1.7
        true
        {340c2bbc-ce74-4362-90b5-7c26312808ef}

        Java Console
        6.0.24
        true
        {CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}

        RealPlayer Browser Record Plugin
        14.0.1
        true
        {ABDE892B-13A8-4d1b-88E6-365A6E755758}

        Java Quick Starter
        1.0
        true
        jqs@sun.com

        IBM CCK
        2.1.1
        true
        IBM-cck@firefox-extensions.ibm.com

        Logitech Device Detection
        1.21.0.11
        true
        DeviceDetection@logitech.com

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.history_expire_days.mirror
        20

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage
        http://w3.ibm.com/

        browser.startup.homepage_override.buildID
        20110413222027

        browser.startup.homepage_override.mstone
        rv:2.0.1

        dom.disable_open_during_load
        false

        dom.disable_window_move_resize
        true

        dom.disable_window_open_feature.status
        false

        extensions.lastAppVersion
        4.0.1

        font.size.variable.x-western
        32

        network.cookie.prefsMigrated
        true

        network.http.proxy.version
        1.0

        places.database.lastMaintenance
        1305571296

        places.history.expiration.transient_current_max_pages
        96445

        places.last_vacuum
        1300888500

        print.print_printer
        Microsoft Office Document Image Writer

        print.printer_Microsoft_Office_Document_Image_Writer.print_bgcolor
        false

        print.printer_Microsoft_Office_Document_Image_Writer.print_bgimages
        false

        print.printer_Microsoft_Office_Document_Image_Writer.print_command

        print.printer_Microsoft_Office_Document_Image_Writer.print_downloadfonts
        false

        print.printer_Microsoft_Office_Document_Image_Writer.print_edge_bottom
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_edge_left
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_edge_right
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_edge_top
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_evenpages
        true

        print.printer_Microsoft_Office_Document_Image_Writer.print_footercenter

        print.printer_Microsoft_Office_Document_Image_Writer.print_footerleft
        &PT

        print.printer_Microsoft_Office_Document_Image_Writer.print_footerright
        &D

        print.printer_Microsoft_Office_Document_Image_Writer.print_headercenter

        print.printer_Microsoft_Office_Document_Image_Writer.print_headerleft
        &T

        print.printer_Microsoft_Office_Document_Image_Writer.print_headerright
        &U

        print.printer_Microsoft_Office_Document_Image_Writer.print_in_color
        true

        print.printer_Microsoft_Office_Document_Image_Writer.print_margin_bottom
        0.5

        print.printer_Microsoft_Office_Document_Image_Writer.print_margin_left
        0.5

        print.printer_Microsoft_Office_Document_Image_Writer.print_margin_right
        0.5

        print.printer_Microsoft_Office_Document_Image_Writer.print_margin_top
        0.5

        print.printer_Microsoft_Office_Document_Image_Writer.print_oddpages
        true

        print.printer_Microsoft_Office_Document_Image_Writer.print_orientation
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_pagedelay
        500

        print.printer_Microsoft_Office_Document_Image_Writer.print_paper_data
        1

        print.printer_Microsoft_Office_Document_Image_Writer.print_paper_height
        11.00

        print.printer_Microsoft_Office_Document_Image_Writer.print_paper_size_type
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_paper_size_unit
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_paper_width
        8.50

        print.printer_Microsoft_Office_Document_Image_Writer.print_reversed
        false

        print.printer_Microsoft_Office_Document_Image_Writer.print_scaling
        1.00

        print.printer_Microsoft_Office_Document_Image_Writer.print_shrink_to_fit
        true

        print.printer_Microsoft_Office_Document_Image_Writer.print_to_file
        false

        print.printer_Microsoft_Office_Document_Image_Writer.print_unwriteable_margin_bottom
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_unwriteable_margin_left
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_unwriteable_margin_right
        0

        print.printer_Microsoft_Office_Document_Image_Writer.print_unwriteable_margin_top
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_bgcolor
        false

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_bgimages
        false

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_command

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_downloadfonts
        false

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_edge_bottom
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_edge_left
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_edge_right
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_edge_top
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_evenpages
        true

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_footercenter

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_footerleft
        &PT

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_footerright
        &D

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_headercenter

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_headerleft
        &T

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_headerright
        &U

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_in_color
        true

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_margin_bottom
        0.5

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_margin_left
        0.5

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_margin_right
        0.5

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_margin_top
        0.5

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_oddpages
        true

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_orientation
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_pagedelay
        500

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_paper_data
        1

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_paper_height
        11.00

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_paper_size_type
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_paper_size_unit
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_paper_width
        8.50

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_reversed
        false

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_scaling
        1.00

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_shrink_to_fit
        true

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_to_file
        false

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_unwriteable_margin_bottom
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_unwriteable_margin_left
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_unwriteable_margin_right
        0

        print.printer_usgu5laa-217-02-600_E_Crescent_Rd.-Lansing.print_unwriteable_margin_top
        0

        privacy.sanitize.migrateFx3Prefs
        true

        security.enable_ssl2
        true

        security.enable_tls
        false

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        ATI Mobility Radeon HD 3400 Series

        Vendor ID
        1002

        Device ID
        95c4

        Adapter RAM
        Unknown

        Adapter Drivers
        ati2dvag

        Driver Version
        8.503.2.2000

        Driver Date
        8-18-2008

        Direct2D Enabled
        Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer.

        DirectWrite Enabled
        false (0.0.0.0, font cache n/a)

        WebGL Renderer
        (WebGL unavailable)

        GPU Accelerated Windows
        0/1

    

Actual Results:  
Several sets of words were not visible.

Expected Results:  
Text should be readable.
(Reporter)

Comment 1

8 years ago
Created attachment 532732 [details]
screenshot of the upgrade page in the problem state

Updated

8 years ago
Version: unspecified → 4.0 Branch
Please try http://support.mozilla.com/en-US/kb/Safe+Mode
btw: you should upgrade your graphic card driver.

Comment 3

8 years ago
I get the same problem on that page if I increase the text size. To reproduce:

1) Load the page
2) Enable View > Zoom > Zoom text only
2) Press Ctrl-plus a few times to increase the font size

Comment 4

7 years ago
I can reproduce it according to comment 3, on linux. However, you are using a quite large default font: "font.size.variable.x-western 32".

But it is quite possible the page's CSS was intentionally designed to do this (clip/hide overflowing text) so this may not be a Firefox bug.
Status: UNCONFIRMED → NEW
Component: General → Layout: Text
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: 4.0 Branch → 2.0 Branch
Yeah, this is definitely a bug in the page.  We need to fix that.
Component: Layout: Text → www.mozilla.com
Product: Core → Websites
QA Contact: layout.fonts-and-text → www-mozilla-com
Version: 2.0 Branch → unspecified

Comment 6

7 years ago
Steven, can you investigate?
Assignee: nobody → steven
(Assignee)

Comment 7

7 years ago
This was indeed due to the "font.size.variable.x-western 32" setting in comment #4. Since other elements on this page are pixel-specific (width, image sizes, etc.), we'll fix the base font size as well.

Done in trunk in r89368. Merged to stage in r89369.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
qa-verified-trunk http://www-trunk.stage.mozilla.com/en-US/firefox/4.0.1/whatsnew/
Keywords: qawanted

Comment 9

7 years ago
I hate to say it, but I'm getting a similar problem with overlapping/hidden text on the new page linked in comment 8.

BE A WEB HERO is getting wrapped onto 2 lines at my default font size, and that's pushing down the text below it so it's hidden behind the "Get Up and Go" box. Decreasing the font size fixes it.

Actually, the page layout gets badly broken as the text size is increased.

Comment 10

7 years ago
Created attachment 536443 [details]
Screenshot of what's new page at default font size, showing hidden text

Comment 11

7 years ago
Created attachment 536446 [details]
Screenshot of what's new page when text is made bigger
(Assignee)

Comment 12

7 years ago
(In reply to comment #9)
> BE A WEB HERO is getting wrapped onto 2 lines at my default font size, and
> that's pushing down the text below it so it's hidden behind the "Get Up and
> Go" box. Decreasing the font size fixes it.

From the screenshot you posted, it appears that the fonts on the page are all falling back to a base serif font. Do you have the "Allow pages to choose their own fonts, instead of my selections above" option checked in the Content > Advanced... option window?

Regardless, I don't think this is the same issue in the original bug here - If you think it's a continuing issue, please do file another bug though. Thanks.
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.