Cannot copy attachment from inbound email to outbound

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Neil Parks, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:5.0a2) Gecko/20110512 Firefox/5.0a2
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:5.0a2) Gecko/20110513 Thunderbird/3.3a4pre

This may be related to Bug 392545 but I would not call it a duplicate.

  Application Basics
    Name: Thunderbird
    Version: 3.3a4pre
    User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0a2) Gecko/20110513 Thunderbird/3.3a4pre

I do not recall having this problem with Tbird 3.1.  It started when I switched to the Miramar nightly 3.3a4 builds.

I cannot copy an attachment from an inbound email to an outbound email.  When I try, the recipient of my message gets the following nonsense instead of the attachment:

--------------060302000000090004000001
Content-Type: application/x-zip-compressed;
 name="sparky-pgms.zip"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="sparky-pgms.zip"

Thisbodypartwillbedownloadedondemand
--------------060302000000090004000001--


In order to prevent this, I must save the inbound attachment to disk, and then in the outbound composer window attach it from disk.  When I do that, the attachment is properly added to the outbound msg.


Reproducible: Always

Steps to Reproduce:
1. Open an inbound email with an attachment.

2. Start writing a new outbound message.

3. Drag the attachment from the inbound mail to the appropriate place on the composer window.

4. Send the outbound message.

Actual Results:  
The attachment was replaced by a cryptic text line.

Expected Results:  
The attachment should be copied in full to the outbound message.
Whiteboard: dupme
See Also: → bug 581515

Comment 1

2 years ago
I could not reproduce this with nihgtly build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.