Last Comment Bug 657548 - Remove duplicate and unused CIDs from nsContentCID.h and nsLayoutCID.h
: Remove duplicate and unused CIDs from nsContentCID.h and nsLayoutCID.h
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Craig Topper
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-16 22:25 PDT by Craig Topper
Modified: 2011-05-19 06:18 PDT (History)
4 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove duplicate and unused CIDs from nsContentCID.h and nsLayoutCID.h (12.99 KB, patch)
2011-05-16 22:26 PDT, Craig Topper
jst: review+
Details | Diff | Review
Part 2: Remove more unused CIDs. (4.52 KB, patch)
2011-05-16 23:47 PDT, Craig Topper
jst: review+
Details | Diff | Review

Description Craig Topper 2011-05-16 22:25:23 PDT
nsContentCID.h and nsLayoutCID.h have several CIDs duplicated. Fortunately, they have identical values.

While reviewing I also found several unused CIDs so I'm removing those as well. I don't claim it to be a complete review and there could still be others that are unused.
Comment 1 Craig Topper 2011-05-16 22:26:15 PDT
Created attachment 532870 [details] [diff] [review]
Remove duplicate and unused CIDs from nsContentCID.h and nsLayoutCID.h
Comment 2 Craig Topper 2011-05-16 22:29:16 PDT
Comment on attachment 532870 [details] [diff] [review]
Remove duplicate and unused CIDs from nsContentCID.h and nsLayoutCID.h

This patch also moves the CID for audio element to ContentCID.h since that's where the other elements live.

All the duplicates were left in the file appropriate to where the implementation lives.
Comment 3 Craig Topper 2011-05-16 23:47:14 PDT
Created attachment 532875 [details] [diff] [review]
Part 2: Remove more unused CIDs.
Comment 4 Johnny Stenback (:jst, jst@mozilla.com) 2011-05-18 09:06:22 PDT
Comment on attachment 532875 [details] [diff] [review]
Part 2: Remove more unused CIDs.

r=jst!

Note You need to log in before you can comment on or make changes to this bug.