appcached html pages don't make use of appcache content

RESOLVED DUPLICATE of bug 651441

Status

()

Core
Networking: HTTP
--
major
RESOLVED DUPLICATE of bug 651441
7 years ago
7 years ago

People

(Reporter: Remy Sharp, Unassigned)

Tracking

2.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

My manifest tells the browser to cache two pages:

1. "this page", i.e. index.html
2. two.html - a second page the user can navigate to

Whilst I'm on the two.html cached page, although this particular file comes from the manifest, it's requesting content that we already have stored in the manifest via the server.

Reproducible: Always

Steps to Reproduce:
1. visit http://appcachetest.duostack.net/log.html in a WebSocket supported browser - ensure that some content is appearing in the log (favicon should appear as it's the subsequent request after the log.html request)
2. visit http://appcachetest.duostack.net/index.html in Firefox
3. accept the offline content
4. refresh - notice that foo.js isn't requested as it's in the manifest
5. navigate to two.html - notice this also isn't in the request log as it's in the manifest
6. notice that foo.js (on two.html) *is* being requested, as seen in the logs.

Actual Results:  
See steps to produce - i.e. foo.js is requested although it's in the cache.

Expected Results:  
foo.js should not be requested as it's in the local cache.

Updated

7 years ago
Component: Developer Tools → Networking: HTTP
Product: Firefox → Core
QA Contact: developer.tools → networking.http
Version: unspecified → 2.0 Branch

Comment 1

7 years ago
Confirming the issue. According to the spec[1]:
"If document was loaded from an application cache, and that application cache still exists (it is not now obsolete)
    Associate document with the application cache from which it was loaded. Invoke, in the background, the application cache download process for that application cache's application cache group, with document as the cache host."

[1] http://www.w3.org/TR/html5/offline.html#concept-appcache-init

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
two.html doesn't have a "manifest" attribute on <html>.  So this looks like bug 651441.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 651441
You need to log in before you can comment on or make changes to this bug.