Closed Bug 657571 Opened 9 years ago Closed 3 years ago

See if we can remove the hack that disables incremental link on Windows debug builds

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 906119

People

(Reporter: standard8, Unassigned)

References

Details

Bug 653662 disabled incremental links for libxul on windows due to developers and build slaves hitting a hard-coded limit in Visual Studio for the size of the incremental link file.

If possible, we should re-enable incremental linking for libxul asap as this will hurt some developers.

Possible ways to get this re-enabled:

* Fix bug 590996 and then disable incremental linking via mozconfigs if necessary.
* Upgrade our builders to a newer Visual Studio version, this also requires jemalloc to be enabled. I'm not sure this will fix the developer issues that were seen there though.

If folks want to do improvements to the current disabling (e.g. 32/64 bit) I suggest they are done as separate bugs.
Version: unspecified → Trunk
Depends on: 696627
Depends on: 700959
Depends on: 703845
Depends on: 703852
This got removed in bug 906119
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906119
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.