Last Comment Bug 657619 - the webgl program works differently on windows7, but works correctly on firefox 4 linux version
: the webgl program works differently on windows7, but works correctly on firef...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: 2.0 Branch
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
http://osgjs.org/osgjs/examples/shado...
Depends on: 657748
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-17 07:30 PDT by Cedric Pinson
Modified: 2011-05-24 08:29 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
the full example (1.80 MB, application/octet-stream)
2011-05-18 06:16 PDT, Cedric Pinson
no flags Details

Description Cedric Pinson 2011-05-17 07:30:20 PDT
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/534.24 (KHTML, like Gecko) Ubuntu/11.04 Chromium/11.0.696.68 Chrome/11.0.696.68 Safari/534.24
Build Identifier: firefox 4.0.1

I made a shadow webgl example.
I know that it can be tricky because of Angle and there is chance it's related. btw, the program works perfectly on linux (chromium and firefox). On windows7 it works for chrome but not for firefox, it produces weird visual glitch.

Reproducible: Always

Steps to Reproduce:
1. open this url on firefox 4.0.1 on windows 7 http://osgjs.org/osgjs/examples/shadow/index.html
2. open the same page on firefox linux, it works
3.


Expected Results:  
the behaviour should be the same on both plateform
Comment 1 Cedric Pinson 2011-05-17 07:50:22 PDT
after testing again it seems to works sometime on chrome but most of the case it produces a glitch too (chrome 11).
Comment 2 Paul Rouget [:paul] 2011-05-17 21:45:51 PDT
What do you see on Windows?
Comment 3 Cedric Pinson 2011-05-18 06:16:26 PDT
Created attachment 533264 [details]
the full example

Some extra informations with screenshoots, version ...

I have nvidia driver 270 series with Quadro FX 880M
Windows7 64 bits
chrome version: 11.0.696.68
firefox 4 version: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

to run the example go in example/shadow and open index.html

the screenshoots with nativegl are what is expected
to produce the screenshoots with native gl I did:
for chrome I ran chrome.exe --use-gl=desktop
for firefox I have enabled it with about:config force native gl
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-05-18 10:14:00 PDT
Can you forward this bug to ANGLE?
http://code.google.com/p/angleproject/issues/list
Comment 5 Cedric Pinson 2011-05-18 10:26:14 PDT
I did here http://code.google.com/p/angleproject/issues/detail?id=157
Comment 6 Cedric Pinson 2011-05-19 06:35:46 PDT
http://code.google.com/p/angleproject/issues/detail?id=157 seems to have been fixed in canary build of chrome with a recent revision of Angle.
I have tested yet
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2011-05-19 06:50:14 PDT
Then that will be fixed by bug 657748
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2011-05-24 08:29:07 PDT
Should be fixed by the ANGLE update, reopen if needed.

Note You need to log in before you can comment on or make changes to this bug.