Closed Bug 657755 Opened 8 years ago Closed 8 years ago

[PATCH] Missing close button for Event dialog under Gnome3

Categories

(Calendar :: Dialogs, defect, minor)

Lightning 1.0b2
All
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alexandre.f.demers, Assigned: alexandre.f.demers)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.35 (KHTML, like Gecko) Chrome/13.0.762.0 Safari/534.35
Build Identifier: 1.0b2

When opening an event in the calendar, there is no Close button available to use if nothing was changed. We have to go through Edit -> Close. Since we may want to have a quick look at an event without editing it, there should be a close button.

Reproducible: Always

Steps to Reproduce:
Open an event. Look at the window.

Actual Results:  
There is no close button. We have to go through Edit -> Close

Expected Results:  
There should be a close button.
Version: unspecified → Lightning 1.0b2
Component: Lightning Only → Dialogs
You mean a toolbarbutton? What about just closing the window using the OS controls?
I don't mean a toolbar button. I'd like to use the OS controls, but there is none available for that dialog, well under Gnome at least (look at the screenshot I'm adding). I'll check under Windows and add more info.
Attached image Event dialog
I checked under Windows and KDE and both show a close button. So it only applies to Gnome (I'm using Gnome 3, so it may not even apply to Gnome 2).
Severity: enhancement → minor
OS: All → Linux
Priority: -- → P3
Summary: Add a close button to event window → Missing close button for Event dialog under Gnome3
This doesn't apply to gnome 2. I don't think we should add a toolbarbutton extra for this purpose, but find out why the OS buttons are gone and try to get them back.
I agree with you. In fact, this is why I renamed the bug.
It seems related with how Gnome 3 handles some kind of windows, particularly dialog window. This may be a clue: http://mail.gnome.org/archives/gnome-shell-list/2011-May/msg00272.html
see bug 608934 for the Firefox equivalent of this bug
Maybe we can use a similar workaround as in Bug 662244.
Status: UNCONFIRMED → NEW
Ever confirmed: true
As stated, there is no close button under Gnome3 for dialog. I just used the same trick applied for the "About" dialog.
Attachment #578495 - Flags: review?
Summary: Missing close button for Event dialog under Gnome3 → [PATCH] Missing close button for Event dialog under Gnome3
Why should we override the default behavior of the GNOME3 desktop which seems to behave unexpectedly? Adding workaround to our code, like that one proposed, does not seem like the correct approach to me.
While I do agree with you, it seems Gnome devs think differently about how a dialog window should be used and what it should be. Please, see link in comment 7 and bug 662244 for more info on the subject. If you have a different solution to propose,  you are welcome to do it and I'll be happy to help you implement it.
Comment on attachment 578495 [details] [diff] [review]
make sure close button's available for event dialog

r=philipp
Attachment #578495 - Flags: review? → review+
Assignee: nobody → alexandre.f.demers
Status: NEW → ASSIGNED
Priority: P3 → --
Oh this has needed checkin for a while now, sorry. I've decided to slightly change the code to avoid the need for the preprocessor in this file. See the following revision on hg for details
Keywords: checkin-needed
Pushed to comm-central changeset f7d035d67962
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
Depends on: 752206
You need to log in before you can comment on or make changes to this bug.