Last Comment Bug 657769 - nsIDOMWindowUtils.FindElementWithViewId uncaught exception - failure code: 0x80040111
: nsIDOMWindowUtils.FindElementWithViewId uncaught exception - failure code: 0...
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 7
Assigned To: Benjamin Stover (:stechz)
:
Mentors:
https://support.mozilla.com/en-US/kb/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-17 14:17 PDT by Ioana Chiorean
Modified: 2011-07-28 15:24 PDT (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
error screenshot (51.68 KB, image/png)
2011-05-18 02:03 PDT, Cristian Nicolae (:xti)
no flags Details
nsIDOMWindowUtils.FindElementWithViewId uncaught exception (1.35 KB, patch)
2011-05-31 10:36 PDT, Benjamin Stover (:stechz)
mbrubeck: review+
Details | Diff | Review

Description Ioana Chiorean 2011-05-17 14:17:14 PDT
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:6.0a1)Gecko/20110517
Firefox/6.0a1 Fennec/6.0a1
Device: Google Nexus S
OS: Android 2.3

I got the error after testing with Zippity but I don't know if it is related to this test run. 

Error text:
uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindowUtils.FindElementWithViewId]" nresult: "0x800040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: chrome://browser/content/bindings/browserjs ::  <TOP_LEVEL> :: line 336" data:no]

Screenshot: https://picasaweb.google.com/116017172139610272348/WORK#5607693701711723730
Comment 1 Tony Chung [:tchung] 2011-05-17 17:57:26 PDT
also reproduced by simply loading this URL.  can repro on Xoom also.

https://support.mozilla.com/en-US/kb/sync-firefox-between-desktop-and-mobile
Comment 2 Cristian Nicolae (:xti) 2011-05-18 01:27:00 PDT
It's reproducing also on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:6.0a1)Gecko/20110517
Firefox/6.0a1 Fennec/6.0a1
Device: HTC Desire
OS: Android 2.2

I've browsed to http://wwww.mozilla.com/en-US/m/ and for every webpage refresh it's displayed again in error console.
Comment 3 Cristian Nicolae (:xti) 2011-05-18 02:03:33 PDT
Created attachment 533212 [details]
error screenshot

I've noticed another error on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:6.0a1)Gecko/20110517
Firefox/6.0a1 Fennec/6.0a1
Device: HTC Desire
OS: Android 2.2

uncaught exception: [Exception... "Component returned failure
code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE)
[nsIDOMWindowUtils.setDisplayPortForElement]" nsresult:
"0x80070057 (NS_ERROR_ILLEGAL_VALUE)" location: "JS frame ::
chrome://browser/content/bindings/browser.js :: <TOP_LEVEL> ::
line 445" data:no]
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-18 05:33:21 PDT
Ben - I'm worried this bug could be hiding other issues. Can you do some investigation?
Comment 5 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-24 08:16:01 PDT
(In reply to comment #4)
> Ben - I'm worried this bug could be hiding other issues. Can you do some
> investigation?

I've hit this when trying to reproduce bug 658315 so this it could be dupe. I also have added a stack in bug 658315 :)
Comment 6 Benjamin Stover (:stechz) 2011-05-31 10:36:44 PDT
Created attachment 536343 [details] [diff] [review]
nsIDOMWindowUtils.FindElementWithViewId uncaught exception
Comment 7 Benjamin Stover (:stechz) 2011-05-31 10:37:45 PDT
This is a pretty harmless error, but a try/catch fixes it. We return not available if the presshell isn't around yet:
http://mxr.mozilla.org/mozilla-central/source/dom/base/nsDOMWindowUtils.cpp#1053
Comment 8 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-06-08 17:36:53 PDT
fyi: just hitting the submit button will spark 2 of these errors on : http://people.mozilla.com/~nhirata/html_tp/formsninput.html
Comment 9 Benjamin Stover (:stechz) 2011-06-09 10:01:54 PDT
Pushed http://hg.mozilla.org/mozilla-central/rev/ddf82c182c85
Comment 10 Anna (Waverley) 2011-06-10 06:08:21 PDT
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110610 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.