Allow admins to see the error details/tracebacks during bulk compatibility check

RESOLVED FIXED in 6.0.10

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: kumar)

Tracking

unspecified
6.0.10

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Please add a way to see the error details/tracebacks @ https://addons.allizom.org/z/en-US/admin/validation

screenshot: http://screencast.com/t/BRTeR731rK
What does this mean?  your link is a 404
I talked to Kumar about what this bug is about.  This doesn't need to be exposed in the UI at all.  This bug should be "Log Validation errors more verbosely" and on the offchance we run across this, it'll be in the logs and we can tell what the problem is from there.
(Reporter)

Comment 3

7 years ago
Created attachment 533178 [details]
screenshot

We show the number of errors on the page but do not provide a way to see what the errors are. Kumar said it would be pretty easy to add this feature.
As of this fix it will be easier to find these exceptions in the logs: https://github.com/jbalogh/zamboni/commit/d501dc1da538a07ea9ad4cf04f2d370d10146189

Adding a CSV download is still a quick fix so we can add it later if we still need it
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.