Last Comment Bug 657862 - SVG arc path segments are broken
: SVG arc path segments are broken
Status: RESOLVED FIXED
nominated by bz near comment 2
: regression
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Jonathan Watt [:jwatt]
:
: Jet Villegas (:jet)
Mentors:
Depends on: 792058
Blocks: 589648
  Show dependency treegraph
 
Reported: 2011-05-17 21:15 PDT by Geoff Lankow (:darktrojan)
Modified: 2013-12-27 14:36 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected


Attachments
SVG circle (587 bytes, image/svg+xml)
2011-05-17 21:15 PDT, Geoff Lankow (:darktrojan)
no flags Details
Screenshot in Nightly (4.30 KB, image/png)
2011-05-17 21:18 PDT, Geoff Lankow (:darktrojan)
no flags Details
patch (1.03 KB, patch)
2011-05-18 04:53 PDT, Jonathan Watt [:jwatt]
longsonr: review+
Details | Diff | Splinter Review

Description Geoff Lankow (:darktrojan) 2011-05-17 21:15:00 PDT
Created attachment 533172 [details]
SVG circle

This SVG file (created in Inkscape) should display a circle. Instead it looks like the top half has been moved to the right.
Comment 1 Geoff Lankow (:darktrojan) 2011-05-17 21:18:48 PDT
Created attachment 533176 [details]
Screenshot in Nightly

This screenshot is on Nightly (6.0) - I'm told on IRC that it doesn't occur on 5.0, and can confirm it doesn't in 4.0.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2011-05-17 22:35:02 PDT
Looks like this regressed in http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=45b20f137549&tochange=46fdf12082d4

jwatt?  You have some path changes in there.
Comment 3 Jonathan Watt [:jwatt] 2011-05-18 02:15:29 PDT
Thanks for the bug report and nice reduced testcase, Geoff! I'll look into this.
Comment 4 Jonathan Watt [:jwatt] 2011-05-18 04:53:14 PDT
Created attachment 533240 [details] [diff] [review]
patch
Comment 5 Robert Longson 2011-05-18 05:06:01 PDT
Comment on attachment 533240 [details] [diff] [review]
patch


Can you do a reftest? Don't forget to specify shape-rendering="crispEdges" since we're dealing with curves.
Comment 6 Jonathan Watt [:jwatt] 2011-05-20 12:57:42 PDT
Pushed http://hg.mozilla.org/mozilla-central/rev/202c87382b20 (with test).

Thanks again, Geoff.
Comment 7 Robert Longson 2011-05-20 13:58:38 PDT
Do you need to land this on Aurora too as it's a regression there isn't it?
Comment 8 Jonathan Watt [:jwatt] 2011-05-20 14:03:16 PDT
No, Aurora's fine. Thanks for checking though.
Comment 9 Christopher Blizzard (:blizzard) 2011-05-26 14:55:38 PDT
Clearing tracking 6 flag since this landed before Fx 6 Aurora was cut.

Note You need to log in before you can comment on or make changes to this bug.