FF 4.0.1 fails to display new window on dual screen setups

RESOLVED DUPLICATE of bug 632749

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 632749
7 years ago
7 years ago

People

(Reporter: Oliver Henriot, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Cmd-N (New window) creates a new window which does not display, cannot be accessed and cannot be closed.

Occurs on a dual-screen system with external screen used as main display and laptop screen used as secondary.
Not dependant on dock position.

Not dependant on installed addons.
Not dependant on profile parameters (occurs even with a new profile).
Could be due to left-overs from previous versions of FF.
Only occurs if higlighted window is on secondary screen, no matter how many windows or tabs are opened. Does not occur if highlighted window is on main display, even if there are windows opened on secondary display.
If re-starting in fail-proof mode, all windows created using this procedure (higlight window on secondary screen, open new window) will open cascaded. Passed a certain number of such windows, the first one opened is one pixel wide and full screen height.
Occurs in fail-proof mode, all addons deactivated.
Re-installing FF 4.0.1 from downloaded dmg does not solve the problem (initial FF 4 installation done via automatic upgrade).

Reproducible: Always

Steps to Reproduce:
1. Open FF 4.0.1
2. Place FF window on secondary screen (laptop screen) and higlight that window
3. Press Cmd-N (new window)

Actual Results:  
New window appears in windows list but cannot be accessed, displayed, or closed.

Expected Results:  
New window should appear and be accessible.

Does not seem to be systematic, same setup (dual screen macbook pro with MacOS X, dual screen with main screen set to external) on different hardware is not affected.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 632749
You need to log in before you can comment on or make changes to this bug.