PGO Tests require enablePrivilege

RESOLVED DUPLICATE of bug 641829

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 641829
7 years ago
5 months ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The PGO tests harness here: http://mxr.mozilla.org/mozilla-central/source/build/pgo/index.html?force=1

requires enablePrivilege to work.  This is going to break when we turn on E10S.

We have two options:
1. Move these tests into a subset of mochitests and run them that way.
2. Change these tests to use special powers so that we can avoid the enablePrivilege calls.

These tests are run after PGO builds are created, on the build machines themselves (as I recall), so any error here will cause the build to go red, and stop all further testing.

These tests are also currently run by the Valgrind enabled tinderboxes, but the Valgrind tests might be moving away from these toward something more representative of normal browsing.
Yep. These aren't tests, this is just the HTML that gets run during a PGO profiling run to provide some input to the optimizer.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 641829

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.