Closed Bug 658044 Opened 11 years ago Closed 4 years ago

Default theme description in Add-ons Manager loses localization when a custom Persona is applied

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sidrabbit, Unassigned)

References

Details

(Keywords: l12y, regression)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110518 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110518 Firefox/6.0a1

I'm using Nightly with Russian locale. When I install a custom Persona, default theme description in Add-ons Manager is shown in English, not in Russian as it should.

Reproducible: Always

Steps to Reproduce:
1. Use non-English version of Nightly.
2. Apply a custom Persona.
3. Open Add-ons Manager.

Actual Results:  
Default theme description is shown in English.

Expected Results:  
Default theme description should remain localized.
I can confirm against de-DE locale.
You have to remove any Personas to get the localized Theme Description back.

Doesn't this rather belong to Toolkit/AOM?
Confirming. It works fine in 4.0, so it's a regression.
Status: UNCONFIRMED → NEW
Component: Localization → Add-ons Manager
Ever confirmed: true
Keywords: regression
OS: Windows 7 → All
Product: Core → Toolkit
QA Contact: localization → add-ons.manager
Hardware: x86 → All
Version: unspecified → Trunk
Keywords: l12y
Can one of you please do a regression test? Does that also affect Aurora builds or only the Nightly?
I'm very surprised that this works in 4.0, did you re-open the add-ons manager between enabling the persona and checking the theme's description?

At the moment we don't look in preferences for localised descriptions for disabled add-ons because we expect that their preferences and locales won't be available. The default theme is kind of a special case here.
(In reply to comment #5)
> Can one of you please do a regression test? Does that also affect Aurora
> builds or only the Nightly?
I guess I need localized nightly to find regression range. Localized nightlies are stored ftp.mozilla.org only for one week. Oldest nightly http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-05-13-03-mozilla-central-l10n/ is affected by this bug.
Just verified that this bug is present in Firefox 4. You can test this by setting extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.description to a custom string. If that shows up in the UI then the localised string is in use.
(In reply to comment #8)
> Just verified that this bug is present in Firefox 4. You can test this by
> setting extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.description to a
> custom string. If that shows up in the UI then the localised string is in
> use.
No, this bug doesn't present in Firefox 4.0.1, see screenshot.
Dave, could that has been already caused by the landing of the initial patches for the new AOM? We should live the regressionwindow-wanted keyword as long as we do not know the exact bug.
(In reply to comment #9)
> Created attachment 533726 [details]
> Firefox 4.0.1 - Default theme disabled, Persona applied
> 
> (In reply to comment #8)
> > Just verified that this bug is present in Firefox 4. You can test this by
> > setting extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.description to a
> > custom string. If that shows up in the UI then the localised string is in
> > use.
> No, this bug doesn't present in Firefox 4.0.1, see screenshot.

I tested in 4.0.1 too. Did you reopen the add-ons manager after enabling the persona?
(In reply to comment #11)
> (In reply to comment #9)
> > Created attachment 533726 [details]
> > Firefox 4.0.1 - Default theme disabled, Persona applied
> > 
> > (In reply to comment #8)
> > > Just verified that this bug is present in Firefox 4. You can test this by
> > > setting extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.description to a
> > > custom string. If that shows up in the UI then the localised string is in
> > > use.
> > No, this bug doesn't present in Firefox 4.0.1, see screenshot.
> 
> I tested in 4.0.1 too. Did you reopen the add-ons manager after enabling the
> persona?
Ok, I was wrong. It's broken in 4.0.1 too. Default theme loses localization after reopening addons manager.
Still a regression from 3.6. The initial new add-ons manager code didn't support localised preferences at all, but when we fixed that in bug 553094 we introduced the issue of not doing it for disabled add-ons.
Blocks: 553094
Keywords: regression
Duplicate of this bug: 1449009
Duplicate of this bug: 1402719
I wonder how much of this can be simplified with the advent of Fluent. Also the demise of complete themes, of course...
As noted in bug 1449009, this can also be seen in the Customize page.
For some reason this became worse, now the text is in English no matter what theme is selected.
(In reply to Itiel from comment #18)
> For some reason this became worse, now the text is in English no matter what
> theme is selected.

Please file a new bug for this.
See Also: → 1458601
Not sure how or why, but it's fixed now. Marking as RESOLVED FIXED.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
WFM is the correct resolution when we can't identify what fixed this.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.