Draft not deleted after successful sending (online) when message was originally composed/sent/saved to outbox while working offline (IMAP)

RESOLVED DUPLICATE of bug 549274

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 549274
7 years ago
5 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: TB 3.3a4pre

Draft doesn't get deleted after successful sending (online) when message was originally composed/sent/saved to outbox while working offline (IMAP).

(Remark: It's an IMAP account; not sure, if it has something to do with.)

Reproducible: Always

Steps to Reproduce:
* Go offline
* compose a new message
* message is autom. saved as draft (e. g. every min.)
     [--> another offline problem here: multiple draft versions are saved]
* send message
* message will be stored in outbox
* go online
* send messages from outbox
* previously saved drafts are not deleted
Rosa, did you test in -safe-mode too ?
Component: General → Mail Window Front End
QA Contact: general → front-end
(Reporter)

Comment 2

7 years ago
Yes, same problem in safe mode.
(PS: It's a Gmail account - just for information.)
Whiteboard: dupme

Comment 3

7 years ago
I can confirm this (though I don't have authorisation to change the status). 

I was about to report it as the other half of the same problem - in my case I 
1: Enter Miramar
2: Start to compose a message
3: Hit save (creates a copy in Drafts
4: edit a bit
5: Hit Save (another copy is created in Drafts)
6: Edit more
Send 
Drafts aren't cleared up.

Comment 4

7 years ago
I can confirm this happens when saving offline drafts (and unlike the other duplicate draft issues, this is 100% reproducible)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549274
You need to log in before you can comment on or make changes to this bug.