Last Comment Bug 658084 - Add IDN ccTLDs + XXX to PSL
: Add IDN ccTLDs + XXX to PSL
Status: RESOLVED FIXED
: verified1.9.2
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
:
Mentors:
: 607938 650412 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-18 15:14 PDT by Jothan Frakes
Modified: 2011-06-16 15:45 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.x-fixed
.18-fixed
.20-fixed


Attachments
PSL Add TLDs for Algeria, Bangladesh, Georgia, India, Iran, Korea, Morocco, Oman, Pakistan, Saudi Arabia, Serbia, Syria, Taiwan, Ukraine, Yemen, XXX (3.90 KB, patch)
2011-05-18 15:14 PDT, Jothan Frakes
gerv: review+
dveditz: approval2.0-
dveditz: approval1.9.2.18-
dveditz: approval1.9.1.20-
Details | Diff | Splinter Review
Fix for /220e (690 bytes, text/plain)
2011-05-23 10:37 PDT, Jothan Frakes
no flags Details
fixed: PSL Add TLDs for Algeria, Bangladesh, Georgia, India, Iran, Korea, Morocco, Oman, Pakistan, Saudi Arabia, Serbia, Syria, Taiwan, Ukraine, Yemen, XXX (4.06 KB, patch)
2011-05-23 11:13 PDT, Jothan Frakes
no flags Details | Diff | Splinter Review
Patch v.3 (3.77 KB, patch)
2011-05-24 04:28 PDT, Gervase Markham [:gerv]
dveditz: approval2.0+
dveditz: approval1.9.2.18+
dveditz: approval1.9.1.20+
Details | Diff | Splinter Review

Description Jothan Frakes 2011-05-18 15:14:32 PDT
Created attachment 533439 [details] [diff] [review]
PSL Add TLDs for Algeria, Bangladesh, Georgia, India, Iran, Korea, Morocco, Oman, Pakistan, Saudi Arabia, Serbia, Syria, Taiwan, Ukraine, Yemen, XXX

This is a large patch which incorporates Bug 650412 to add .XXX


Bug 650412				
	xxx		ICM Registry	Sponsored Community	http://www.icmregistry.com

It also incorporates Bug 607938, plus additional IDN ccTLD to sync with the IDN 
Fastrack program at ICANN
(URL: https://www.icann.org/en/topics/idn/fast-track/string-evaluation-completion-en.htm)

Bug 607938				
	Algeria				
		الجزائر	xn--lgbbat1ad8j	Algeria / Al Jazair	Arabic	Arabic
	India				
		بھارت	xn--mgbbh1a71e	Bharat	Urdu	Arabic
		भारत	xn--h2brj9c	Bharat	Hindi	Devanagari
		ভারত	xn--45brj9c	Bharat	Bengali	Bengali
		ਭਾਰਤ	xn--s9brj9c	Bharat	Punjabi	Gurmukhi
		ભારત	xn--gecrj9c	Bharat	Gujarati	Gujarati
		இந்தியா	xn--xkc2dl3a5ee0h	India	Tamil	Tamil
		భారత్	xn--fpcrj9c3d	Bharat	Telugu	Telugu
	Korea, Republic of				
		한국	xn--3e0b707e	Republic of Korea	Korean	Hangul
	Morocco				
		المغرب	xn--mgbc0a9azcg	Morocco / al-Maghrib	Arabic	Arabic
	Oman				
		عمان	xn--mgb9awbf	Oman	Arabic	Arabic
	Serbia				
		срб	xn--90a3ac	srb	Serbian	Cyrillic

New IDN ccTLD Strings
	Bangladesh				
		বাংলা	xn--54b7fta0cc	Bangla	Bangla	Bangla
	Georgia				
		გე	xn--node	ge	Georgian	Georgian (Mkhedruli)
	Iran, Islamic Republic of				
		ايران	xn--mgba3a4fra	Iran	Iran	Arabic
		ایران	xn--mgba3a4f16a	Iran	Iran	Persian
	Pakistan				
		‎‎پاكستان	xn--mgbai9a5eva00b	Pakistan	Urdu	Arabic
		‎‎پاکستان	xn--mgbai9azgqp6j	Pakistan	Urdu	Arabic
	Saudi Arabia				
		السعوديه	xn--mgbqly7cvafr	AlSaudiah	Arabic	Arabic (Variant)
		السعودیة	xn--mgberp4a5d4a87g	AlSaudiah	Arabic	Arabic (Variant)
		السعودیۃ	xn--mgbqly7c0a67fbc	AlSaudiah	Arabic	Arabic (Variant)
	Syrian Arab Republic				
		سوريا	xn--mgbtf8fl	Syria	Arabic	Arabic
		سورية	xn--ogbpf8fl	Syria	Arabic	Arabic
	Taiwan				
		臺灣	xn--nnx388a	Taiwan	Chinese	Simplified Chinese
	Ukraine				
		укр	xn--j1amh	ukr	Ukrainian	Cyrillic
	Yemen				
		اليمن	xn--mgb2ddes	AlYemen	Arabic	Arabic
Comment 1 Jothan Frakes 2011-05-18 15:19:45 PDT
*** Bug 650412 has been marked as a duplicate of this bug. ***
Comment 2 Jothan Frakes 2011-05-18 15:21:28 PDT
*** Bug 607938 has been marked as a duplicate of this bug. ***
Comment 3 Gervase Markham [:gerv] 2011-05-20 06:00:04 PDT
Comment on attachment 533439 [details] [diff] [review]
PSL Add TLDs for Algeria, Bangladesh, Georgia, India, Iran, Korea, Morocco, Oman, Pakistan, Saudi Arabia, Serbia, Syria, Taiwan, Ukraine, Yemen, XXX

r=gerv. Although all of these are no-ops, right?

Gerv
Comment 4 Gervase Markham [:gerv] 2011-05-20 06:16:34 PDT
mozilla-central: http://hg.mozilla.org/mozilla-central/rev/b59363737df0

I will ask for branch approvals in a day or two.

Gerv
Comment 5 Mounir Lamouri (:mounir) 2011-05-20 07:57:59 PDT
Backed out due to xpcshell failure on all platforms.
See: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305900628.1305901763.25019.gz&fulltext=1
Comment 6 Gervase Markham [:gerv] 2011-05-20 09:03:07 PDT
The cause of the failure was this bug; the new TLDs for .pk contain what Firefox things is a non-permitted codepoint (200E). And the Verisign IDN checker agrees:
http://mct.verisign-grs.com/conversiontool/convertServlet?input=%E2%80%8E%E2%80%8E%D9%BE%D8%A7%D9%83%D8%B3%D8%AA%D8%A7%D9%86&type=UTF8

I will check this all back in without that change, and we can open another bug to fix the problem.

Gerv
Comment 7 Gervase Markham [:gerv] 2011-05-20 09:13:32 PDT
Attempt 2: http://hg.mozilla.org/mozilla-central/rev/e961f83ce28c

Gerv
Comment 8 Daniel Veditz [:dveditz] 2011-05-23 10:19:16 PDT
Comment on attachment 533439 [details] [diff] [review]
PSL Add TLDs for Algeria, Bangladesh, Georgia, India, Iran, Korea, Morocco, Oman, Pakistan, Saudi Arabia, Serbia, Syria, Taiwan, Ukraine, Yemen, XXX

This is the patch that got bounced, right? Not approving.

Actually what you checked in the second time looks like what you checked in the first time -- what happened to the test failures? Did \u200E magically become approved in that time? (it's invisible and in the 'punctuation' block so it seems unlikely).
Comment 9 Jothan Frakes 2011-05-23 10:37:33 PDT
Created attachment 534476 [details]
Fix for /220e

This is the two lines, fixed to not include the offending character.
Comment 10 Jothan Frakes 2011-05-23 11:13:57 PDT
Created attachment 534492 [details] [diff] [review]
fixed: PSL Add TLDs for Algeria, Bangladesh, Georgia, India, Iran, Korea, Morocco, Oman, Pakistan, Saudi Arabia, Serbia, Syria, Taiwan, Ukraine, Yemen, XXX

We had two illegal unicode characters that I found in the <.pk> entries, that bled through in a cut-paste operation at my desk.  The unicode characters caused a fail in build.

I determined the source of the error, and have fixed it in the attached file.

This is a replacement for the patch that was failing, I was able to determine that there was an illegal character in the cut-paste of the Arabic and Persian strings for the Pakistan entries that was causing the fail.

The newly attached has validated each way in a round trip conversion test 
[punicode->native->punicode], [native->punicode->native], and is confirmed valid.
Comment 11 Gervase Markham [:gerv] 2011-05-24 04:28:48 PDT
Created attachment 534724 [details] [diff] [review]
Patch v.3

Here is a patch containing the changes which actually ended up on mozilla-central, after backing out the .pk entries (which are now bug 658582). We should handle these changes here, and the other ones in the other bug.

Gerv
Comment 12 Daniel Veditz [:dveditz] 2011-06-01 10:35:12 PDT
Comment on attachment 534724 [details] [diff] [review]
Patch v.3

Approved for 1.9.2.18 and 1.9.1.20, a=dveditz for release-drivers
Approved for the mozilla2.0 repository, a=dveditz for release-drivers
Comment 14 Al Billings [:abillings] 2011-06-16 15:45:12 PDT
Verified for 1.9.2.18 in source.

Note You need to log in before you can comment on or make changes to this bug.